Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to kill gnome-settings-daemon as mentioned at https://wiki.ubuntu.com/Hotkeys/Troubleshooting so that I can examine keyboard events with xev. However, when I do

killall gnome-settings-daemon

gnome-session just restarts it again.

I'm on Ubuntu 11.10.

share|improve this question
    
Sorry, I had put the wrong url in. Now corrected. I'm trying to track down a keycode for a laptop key, and the updated url says to kill gnome-settings-daemon first in case it is eating some events. That's a topic for a whole new question though... – Dave E Jan 7 '12 at 16:45
up vote 4 down vote accepted

11.10...

sudo -e /etc/xdg/autostart/gnome-settings-daemon.desktop

Change X-GNOME-AutoRestart=true to X-GNOME-AutoRestart=false

Save. Does log out/log in suffice? Not sure. Maybe just reboot for simplicity.

share|improve this answer
    
Yup, that did the trick, thanks. I just had to log out and back in again. – Dave E Jan 7 '12 at 16:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.