Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a 64-bit installation of Oneiric. I need to install the ia32-libs package to get some applications (evince, adobe reader) to work. For example, adobe reader is giving the following error: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

However, I am not able to install it since it is showing a dependency on ia32-libs-multiarch, which in turn is showing a dependency on gstreamer0.10-plugins-good:i386. This in turn depends on few other packages.

How can I install these packages safely and still meet all the dependencies.

share|improve this question
add comment

4 Answers

Install the dependencies as usual, but append :i386 to it as in:

sudo apt-get install libgl1-mesa-glx:i386

If you get an impossible situation, try to install the 32-bit C library first, then the other packages:

sudo apt-get install libc6:i386

See also Does the multiarch feature in 11.10 mean the death of force--architecture installs?

share|improve this answer
    
Thank you @Lekensteyn, but it is still not working. The root dependency is gsettings-desktop-schema:i386, and when I try to install it, it tries to uninstall other important packages. –  Swarnendu Biswas Jan 10 '12 at 0:39
add comment

I had the same problem and this worked for me

Create this file:

sudo nano /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=quantal*
Pin-Priority: 2012

Ctrl-X to quit and Y to save

Then do a downgrade:

sudo apt-get dist-upgrade

Then install ia32-libs

sudo apt-get install ia32-libs

Don't forget to delete the preferences file you created so that other updates will be found!

sudo rm /etc/apt/preferences

share|improve this answer
add comment

Amazingly, just do what it says after the failed force install I.E.: "sudo apt-get -f install" This apparently runs a forced install on failed dependency packages for the previous command and resolved my issues for installing Adobe Acrobat 9.5.1 in Ubuntu 11.10.

share|improve this answer
add comment

try to add i386 to your multiarch prefs

dpkg --add-architecture i386
apt-get update
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.