Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a quad-core Gateway computer that is a few years old. I want a minimal installation of Ubuntu, so I'm interested primarily in Ubuntu Server, though Xubuntu is okay too.

When I try the Ubuntu Server 64-bit install CD, I can't install Ubuntu. Whenever I select any menu option (e.g., "Install Ubuntu Server"), the computer restarts.

I tried the Xubuntu alternative install CD with the same problem. The normal Xubuntu install CD works fine, as does a 32-bit Ubuntu Server CD. However, I want to tweak the installation a bit more than the regular Xubuntu install CD allows, I want to use a 64-bit OS, and I'm very curious about why the text-only installation won't work.

Using a flash drive with the USB creator program instead of CDs has the exact same result.

I'd try Lubuntu or plain Ubuntu but I'm lead to believe the problem is with the 64-bit text-only install, not the particular blend of Ubuntu.

The md5 hashes for my .iso files are correct. I also have verified that the CDs work correctly on my Dell laptop, which appears to run everything without issue.

I've tried tweaking some BIOS settings to see if that might make any difference, but it doesn't seem to change anything.

I tried a memory test (see below). My RAM is good. Still, I removed one stick to see if the total amount might make a difference --- it did not.

I tried a few different Boot parameters as suggested here. Specifically, I tried BOOT_DEBUG=2 (which didn't display anything because the system restarted before it could) and the few ways of disabling ACPI (which also did nothing). If there are other boot parameters that are worth trying, let me know.

I tried the 64-bit Ubuntu Server 11.04 CD (instead of 11.10 as I have been trying) with the same problem.

At the moment I'm investigating installing with Lubi.

Anyone know what might be going wrong here or what I should do to figure out what is wrong?

Alternatively, does anyone know how to install a 64-bit OS from a 32-bit liveCD?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Try running the memtest. I had the same simptoms, when I had RAM problem.

share|improve this answer
    
Good idea. Memtest86+ ran without finding any errors, so this does not appear to be the problem. –  Ben Trettel Jan 7 '12 at 15:50
    
Netboot cd iso? cdimage.ubuntu.com/netboot (Select your release, arch, and download mini.iso) –  gajdipajti Jan 7 '12 at 17:30
    
Do netboot Ubuntu Server or Xubuntu alternative isos exist? I don't want plain Ubuntu unless it's unavoidable. Those isos appear to be for the graphical install, which doesn't have the configuration options I want. –  Ben Trettel Jan 7 '12 at 18:31
1  
The netboot iso is only kernel+initrd. It will fire up your machine in alternative install mode, and download the latest packages for install. You can than make the partitions and select the package groups you want (Ubuntu Server) You need the mini.iso –  gajdipajti Jan 7 '12 at 22:18
    
Ah, perfect. I'm installing right now --- I copied the disk image to my USB stick via sudo dd if=mini.iso of=/dev/sdX (where, of course, X varies from system to system). Seems to be working fine so far. Thank you. I will choose your answer if everything else goes smoothly. –  Ben Trettel Jan 7 '12 at 23:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.