Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Fresh install of 11.10 and the gnome panel's volume control doesn't work for headphones but does work for speakers on my laptop.

In sound settings I have Internal Audio Analogue Stereo selected for output (Output tab) and Analogue Speakers selected for Connector. When I plug headphones in, the volume control doesn't work and the volume is maximum through the headphones.

On a side note, only one of my two headphone sockets produces sound too (whereas both worked in 10.04)

share|improve this question
    
This isn't solved because it should work naturally, and not require manual resetting every time. Is there a way to disable the "analog headphones" option so that it stays as it's supposed to? Is there an update to the driver or something that can fix this? –  user54355 Apr 10 '12 at 21:16

2 Answers 2

My laptop has two headphones sockets: headphone socket 2 (the one I was using) is permanently on 100%, whereas socket 1 is actually under the volume control, IF Analogue Speakers is selected. However, even if I have Analogue Speakers selected, it is automatically changed to Analogue Headphones when the headphones are plugged in (to socket 1). The workaround is to manually reset it to Analogue Speakers after plugging in headphones. Every time you plug in headphones. Best keep that Sound Settings window open.

share|improve this answer
    
I have the same issue and found this same workaround. But it's driving me nuts because of it automatically switching. The 100% output headphone socket is marked as an S/PDIF, the other socket is the actual headphones output. (Dell XPS 15) –  Beanow Jan 8 '12 at 14:19
    
I reported this as a bug here: bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/913451 –  Beanow Jan 8 '12 at 15:58

For some reason Analog Headphones does not work as expected - volume is really low even if it's set to 100%.
My solution was to explicitly switch Output to Analogue Speakers in audio settings after headphones are plugged in.

share|improve this answer
    
thanks but as I said in my question, I already have Analogue Speakers selected, not Analogue Headphones –  Hendekagon Jan 7 '12 at 12:09
    
Can you try to change that output option back and forth, what happens then? Do you notice sound level change? –  Andrejs Cainikovs Jan 7 '12 at 12:14
    
ok mystery solved. thanks for prompting me to experiment! what's happening is that headphone socket 2 (the one I was using) is permanently on 100%, whereas socket 1 is actually under the volume control, IF Analogue Speakers is selected. However, even if I have Analogue Speakers selected, it is automatically changed to Analogue Headphones when the headphones are plugged in, but I didn't know that because I'd closed the dialogue. Like you say, you have to manually reset it to Analogue Speakers after plugging in headphones or you'll hear nothing. Another 11.10 bug! –  Hendekagon Jan 7 '12 at 12:44
    
...I should add that socket 2 does not cause automatic selection of Analogue Headphones as socket 1 does –  Hendekagon Jan 7 '12 at 12:46
    
@Hendekagon Can you post your solution as an answer so we can mark this solved? –  Jorge Castro Jan 7 '12 at 18:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.