Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed the Gnome Schedule ( Scheduled tasks ) to automate the backup of the on Ubuntu Lucid computer. The Scheduled tasks run for one time. I added one task and then next time it stoped running. Now everytime i run the application, the icon appears for few seconds in task bar , and application stops. I tried reinstalling and rebooting computer many times but same thing happens . Any solution to this problem? I googled this problem for a long time. I couldn't find the solution for this.

I have found some comments on forum about running the application from terminal , So here it is the output of the warning when ran from terminal,

gnome-schedule
/usr/share/gnome-schedule/mainWindow.py:158: DeprecationWarning: Use the new widget gtk.Tooltip
  tip = gtk.Tooltips ()
/usr/share/gnome-schedule/mainWindow.py:159: DeprecationWarning: Use the new widget gtk.Tooltip
  tip.enable ()
Traceback (most recent call last):
  File "/usr/share/gnome-schedule/gnome-schedule.py", line 74, in <module>
    mainWindow = mainWindow.main(debug_flag, False, pr, manual_poscorrect)
  File "/usr/share/gnome-schedule/mainWindow.py", line 257, in __init__
    self.schedule_reload ()
  File "/usr/share/gnome-schedule/mainWindow.py", line 308, in schedule_reload
    data = self.at.read ()
  File "/usr/share/gnome-schedule/at.py", line 514, in read
    array_or_false = self.parse (line)
  File "/usr/share/gnome-schedule/at.py", line 174, in parse
    if script[-1] == "\n":
IndexError: string index out of range

Update:

Found similar post somewhere online here.

I just don't get it , how that worked for that person in that post.

share|improve this question

1 Answer 1

I figure that out with trial and error and some reading on other posts. I deleted folder named similar to the application which is gnome-schedule from the home folder. That worked for me. Once the Sheduler started, i deleted all the back up folders and other errorneous tasks from the application list. The application works for now.

I don't know , what happened to the app that made it not work for some reason. I am trying read more about how to properly use the Scheduled Tasks app , so that this won't happen again.

Thanks all for reading or not. I hope my answer would help someone in similar problem in future.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.