Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo Thinkpad T61 and the wireless works just fine so I installed Ubuntu straight away only to find that the wireless will not connect, it will see the networks but just not connect. Has anyone managed to solve this all the forums seem to relate to Ubuntu 9.04 and before.

Edit:Sorry about that, I didn't realise that there were 2 models mine is the Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection. Any help is much appreciated.

share|improve this question
    
I looked that laptop up, looks like they can ship with two different WLAN cards...Intel 3945ABG 802.11abg or Intel 4965AGN 802.11abgn. Please run lspci in the terminal and edit your question to include which wireless adapter you have in there. –  titaniumtux Jan 8 '12 at 15:03
    
@Ross - If you see your wireless networks then looks like its working ok. To check if its a problem with your security settings, please see if you can connect with your router security turned off. If it connects, then try with WEP, followed by WPA, followed by WPA2. In each case, ensure you have typed the security key correctly. Usually it should be in uppercase. –  fossfreedom Jan 10 '12 at 23:22
    
I have managed to get it to connect to my router now by disabling the "n" mode and it works fine....except I've noticed that after downloading for around 1-2 mins it stops. It doesn't disconnect or anything just stops. I have tested and I can upload files to my server that are huge and take hours but cannot download them either so it's not just a slow connection. Any ideas? –  Ross Fleming Jan 12 '12 at 20:53
1  
The "n" disabling sorted it :) –  Ross Fleming Jan 13 '12 at 21:05
    
@RossFleming - please add an answer and accept it by clicking the tick button next to the answer. Thank-you. –  fossfreedom Apr 4 '12 at 18:01
add comment

1 Answer 1

up vote 3 down vote accepted

If the machine is running 11.04 or 11.10 you need to disable "n" by running this in a terminal:

gksu gedit /etc/modprobe.d/options.conf

and adding this line to the file:

options iwl4965 11n_disable=1

Reboot and try to connect again.

Ubuntu 12.04LTS solves this problem (I will update if this changes).

Edit: So far versions after and including Ubuntu 12.04LTS do not have this issue with the Intel 4965 wireless card.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.