Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been having some delay issues with my internet connection. It's hard to explain exactly what the issue is, but I can give a few examples. Also it does this with or without my router connected.

-If I try to go to any website, my browser will sit with the loading wheel seemingly doing nothing for about 10-30sec, then the page loads at full speed.

-If I go to YouTube, after about 10-30sec of staring at a white screen, everything except the video previews load, there still white squares (but they do eventually load). Then when I go to play a video, it takes between, 10-30sec for the video to start, but once it starts it almost immediately buffers all the way through at full speed. BUT, yep there's more, about 10-20sec after the video starts it gets paused so the commercial can play...the commercial that should have played before the video ever started.

I have 20Mb/s Down, and 2Mb/s Up, during the day I actually get closer to 30Mb/s Down and 1.7Mb/s Up, then in the evening I get about 18Mb/s Down, and 1.5Mb/s Up.

Speed Test

Ping Test

The only reason my ping test is a B is because It cant test packet loss because I don't have java, I ran the ping test on a Windows computer on the same network, and it was an A and packet loss was at 0%.


    ping -c 4
PING ( 56(84) bytes of data.
64 bytes from ( icmp_req=1 ttl=51 time=33.3 ms
64 bytes from ( icmp_req=2 ttl=51 time=27.5 ms
64 bytes from ( icmp_req=3 ttl=51 time=29.1 ms
64 bytes from ( icmp_req=4 ttl=51 time=29.4 ms

--- ping statistics --- 
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 27.563/29.873/33.335/2.127 ms

Also, here is a link to a Kubuntu user with what sounds like the exact same issue, unfortunately the work around mentioned in the tread didn't really help me.

INFO: Ubuntu 11.10 64bit ASRock M3A770DE mobo W/Realtek RTL8111DL on board NIC

share|improve this question
Slow DNS resolution? How quickly does host respond? – tumbleweed Jan 6 '12 at 23:14
which browser is this.. I had massive problems with FF loading animations (flash, canvas, CSS3) and hanging for a long time before anything would happen. I switched to Chrome and problem solved (although Chrome has it's own set of problems). I know this doesn't solve the problem but might help identify it. – rlemon Jan 6 '12 at 23:40
@tumbleweed I'm not sure if you wanted me to put that in a terminal or not. But I did anyway, and also tried my browser, loads almost instantly, probably because most of its layout is cached in my system. So I tried it was 40sec before anything at all came up on the screen, and at 45sec it was finished loading. I also tried, it began loading after only 6sec, but didn't finish until 57sec. I'm very confused, every other computer in my home is just ridiculously fast. Also rlemon, I'm using Chromium, but have also tried FF. – Relik Jan 7 '12 at 0:48
@Relik: Yes I did. We debug this kind of thing with simple tools, not browsers, they have way too many moving parts. – tumbleweed Jan 7 '12 at 8:32
up vote 3 down vote accepted

Ok, I believe I solved the issue. A few days ago in an attempt to fix sharing issues with samba I modified the file /etc/nsswitch.conf I added wins before dns on the line that normally reads hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4 so now my internet seems to be back to normal speed, even though when I ping for example it still takes 3000ms round trip.

And of course removing wins from the file made my samba shares break again.

share|improve this answer

This could be a problem with your nameservers, specifically that the first one or 2 in the list are timing out and your computer is only getting responses once it goes to the backups. To check what those are set to, run the command in a terminal:

cat /etc/resolv.conf

that should output something like:

# Generated by NetworkManager

With actual IP addresses. You can try pinging each of those nameservers in order to see if they are all responding, and run some sample domain name lookups against them. The following command will look up the IP address of by asking the DNS server at


If any of the DNS servers don't respond or take a long time to respond, you know they are they ones to remove from the list.

A temporary fix is probably to remove the first item in the list and see if things improve.

A permanent fix would be to change the settings in your router to deliver only the working DNS server IPs when you connect your computer to the network by DHCP.

share|improve this answer
Both of the name servers responded fine I think. (4 packets transmitted, 4 received, 0% packet loss, time 3004ms) and the other (4 packets transmitted, 4 received, 0% packet loss, time 3003ms) – Relik Jan 7 '12 at 1:51
Even this website takes about 30sec to start loading every time I refresh it to see if there have been any new answers and about another 30sec to actually finish. – Relik Jan 7 '12 at 2:11
@Relik: 3 seconds round-trip is very very slow for a DNS server. Also, don't ping it, look something up, with host – tumbleweed Jan 7 '12 at 8:32
ok I used it to look up this is what I got host has address has address has address has address mail is handled by 1 mail is handled by 1 mail is handled by 1 Im assuming thats what you wanted me to do was run it in the terminal, if not then just let me know because I am a little unfamiliar with that command. – Relik Jan 7 '12 at 15:11

I found a fix for the 6-10 second or longer delay before Chrome even tries to start connecting to the internet.

In the Chrome Browser go to the pull-down menu and go to 'Settings'. Open 'Show Advanced Settings' at the bottom of the page. Go almost to the bottom of this page to the'System' section and un-check the box and turn off 'Use Hardware Acceleration When Available'.

Hope this works for you too.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.