Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my problem is that the cdrom is listed properly in /etc/mtab file but not in /etc/fstab file.

mtab contents:

/dev/sda1 / ext4 rw,errors=remount-ro,commit=0 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/ryan/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=ryan 0 0
/dev/sr0 /media/Kubuntu\04011.10\040i386 iso9660 ro,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500 0 0
/etc/mtab (END) 

fstab contents:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=c72c38c5-9b1b-4ae6-bafb-860988a3bcae /               ext4    errors=remount-ro 0       0
# swap was on /dev/sda5 during installation
UUID=25639380-c36f-491f-912d-a01477bf0a5c none            swap    sw              0       0

see..no cdrom in fstab. Actual problem was that I wasn't able to use cdrom as a source from synaptic...searched..found out about apt-cdrom...used...got unable to mount error...again searched...found out that apt-get uses sources listed in /etc/apt/sources.list and to add a cdrom to this list ,it must be in fstab....again searched..until now the conclusion is that I have to maually add cdrom to fstab.I'll be using this as help.

But isn't this a problem...manually fixing an important system file..why debian/mint guys are not fixing it?????

System snapshots are from linux mint 11 but I have similar issues with Kubuntu 11.10 both are running as guests using virtual box on windows 7(seeee a linux newbie)

Thanks..

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

mtab is what's currently mounted. fstab is the list of things to mount at boot, and some static mount points for mounting by hand.

You can easily add a cdrom mount point (it looks like apt-cdrom needs one):

/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
share|improve this answer
    
wow...wait "static mount points"...what is it and how I create one..thanks –  rsjethani Jan 8 '12 at 9:25
    
By editing fstab. Everything listed in fstab is mounted at boot, unless there's a noauto option. Then it can still be easy mounted, as all the details are in fstab. With the example I give above, it can be mounted by just typing mount /dev/cdrom0. All the details will come from fstab. –  tumbleweed Jan 8 '12 at 22:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.