Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to play any MP3 encoded song in Rhythmbox, the seek bar is disabled. Upon trying to play the same files in Totem, the same problem appears again.

I think that the problem started after following option C in this guide, and then undoing it.

I've tried reinstalling gstreamer0.1-plugin-ugly, gstreamer0.1-ffmpeg and gstreamer0.1-fluendo-mp3, which are the packages I think Rhythmbox is asking for upon playing a MP3 encoded file.

Running Ubuntu 10.04, recently updated.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

The -ffmpeg package allows playback of mp3s, but not seeking. It's possible that if you have both -plugins-ugly and -ffmpeg installed, Rhythmbox (or any other gstreamer-based media player) will choose to use -ffmpeg istead of the ugly plugin, and you will not be able to seek.

gstreamer0.1-plugin-ugly should cover all of your mp3 needs, so you can safely uninstall the gstreamer0.1-ffmpeg package.

For more background on the issue, see a similar bug reported against Banshee, and the much older gstreamer bug it was eventually closed as a duplicate of. Also note that an mp3 parser is now included in the -good gstreamer plugin, so this issue should not affect newer versions of Ubuntu.

share|improve this answer
    
Removed the package, did work in Totem but not Rhythmbox. Cleaned the library, restarted Rhythmbox and now it works fine! Thank you! –  mei Jan 6 '12 at 20:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.