Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to open password protected [not read only] doc file [saved in LibreOffice] to write, but i cant type. How to solve this problem ?

share|improve this question
    
You can't type the password to open it, or you type the password, open it, but can't edit it? If you can't type at all then activate the onscreen keyboard in System Settings/Universal Access/Typing/Typing Assistant. –  Tom Brossman Jan 6 '12 at 16:56

2 Answers 2

up vote 4 down vote accepted

You can toggle the edit mode using this button:

Toggle edit mode

If the file is write-protected, a message will appear. The content of the message depends on the reason for the write protection:

  • If the file itself is protected (on file system level), you wil be asked to create a copy of that document to work with. To remove the file protection, you will have to change the file's attributes (using a file manager or a terminal using the chmod +w filename command).
  • If the document is saved with write protection (on application level), you will be prompted for the password that was set when the doc was saved.

Please keep in mind that there may be two (different) passwords set for a certain document. LibreOffice allows for setting separate passwords to open a file and to edit it:

Set password dialogue

So, even if it's possible to open a password-protected libreoffice doc, there may be another password set to prevent editing.

share|improve this answer

If you are the creator of the original file, you can save a copy of the file, edit that, and then overwrite the original later, adding the password when you save.

This is only of course if tohuwawohu's answer does not work for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.