Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I suspend my laptop the wifi disconnects obviously, however 9/10 times when it resumes from suspension the wifi is just sitting there on "authentication required" and no popup appears for me to authenticate, even turning off the wifi and back on does not fix it, I need to log out and back in for it to work.

What would be causing this and how may I fix it?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Seems this has a similar post here from the Ubuntu forums.

The Solution that seemed to work was as follows:

I have resolved the same problem very simply.

Click on Applications/System Tools/System Settings.

In the Hardware collection of icons, click on Network, then Wireless.

In the lower right hand corner of the Wireless Connected window (I earlier connected)

click on Configure…

I have Connect Automatically checked (near the top), and Available to all users checked >(near the bottom.

Click on the Wireless Security tab.

In my case for Security I have: WPA & WPA2 Personal

Fill in the Password.

Click Save.

When I restarted the system all went automatically.

share|improve this answer
    
I tried the resolution and it works. However, it is a workaround. When you resume and you don't have the "Available to all users" option checked it should ask for a password. In my case 9 times out of 10 it doesn't ask for it but the status if you click on the network icon in the panel says it is waiting for authentication. I have to either turn off the wifi via a hardware switch or connect to another access-point then disconnect and reconnect to mine. This is a bug and that is why the instructions above are just a workaround. I tried this on Ubuntu 12.04 with Gnome Shell by the way. –  Gabriel Jun 30 '12 at 21:42
add comment

Same here on Gnome3 with both Ubuntu 11.10 and 12.04 beta - however turning wifi off and on again does the trick for be. (works with both soft and hard killswitch)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.