Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used some older Ubuntu (so I guess it used madwifi), now I installed new Ubuntu 11.10, but I got problem with wifi, it uses ath5k - everything works, downloading etc, but if I stay to read some page for example (facebook messages etc) a then I am trying interact with the page, it does not load. I have to reload whole tab...

so the wifi somehow freeze when is in the idle...

I find several people with the same/similar issue:

https://bbs.archlinux.org/viewtopic.php?pid=702230 http://linux.derkeiler.com/Mailing-Lists/SuSE/2010-05/msg00880.html

but I did not find solution... I guess I can recompile madwifi, but this I consider as the last option...

my wifi: Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)

I tried disable ipv6 and install compact wireless drivers, did not help.

Thank you very much!

share|improve this question
add comment

1 Answer

Try the following solution, replacing ath9k with ath5k (you might need to update your kernel, as someone mentions in the comments)?

I'm not sure, but I think the ath5k has an identical option.

That is:

sudo -s
echo "options ath5k nohwcrypt=1" > /etc/modprobe.d/ath5k.conf
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.