Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a pair of 1440 x 900 monitors that I want to run in portrait mode (not mirrored).

When I select 800 x 600 for both, it works, but I am not near the maximum of the monitor hardware nor am I near what appears to be the addressable space of 1600 x 1600.

If I select 1280 x 800 for both, I get the following error:

The selected configuration could not be applied:
requested position/size for CRTC 148 is outside the allowed limit: 
position=(800,0), size=(1280,800), maximum=(1600,1600).

Superficially it appears this error is a bug. A pair of 800 pixels side by side (when in portrait) does not exceed 1600, and of course 1280 does not exceed it.

How can I get this to work. Of course I would prefer a pair set to 1440 x 900 which is the actual LCD resolution, but then of course the 900 side by side pair would total 1800 and so I won't even bother with that.

The correct rotation setting seems to be "counterclockwise". I am using Ubuntu 11.10 and a Radeon HD 5450 and the Catalyst 11.12 for x86-64 architecture. I am dual booting. I had no complaints with the visual quality on Windows 7, it looked good and used the natural resolution (1440 x 900) even in portrait. Thus it seems safe to conclude the hardware can do it but Ubuntu and the driver for Ubuntu is at fault.

Although it would be a shame to do so given the Windows 7 example, I would be willing to buy a new video card if a card and driver combination successfully displays dual monitors in 1440 x 900 (each) non-mirrored portrait on Ubuntu 11.10. Please post a comment if you have this working. At this point I would even consider landscape non-mirrored dual monitors.

share|improve this question
    
Have you tried 800 x 1280 instead? From the output it looks like you are adding a normal screen to a rotated one, and 800 + 1280 > 1600. –  htorque Jan 6 '12 at 11:07
    
There is no 800 x 1280 choice. It's 1280 x 800. –  broiyan Jan 6 '12 at 15:26

1 Answer 1

up vote 0 down vote accepted

You can increase the virtual resolution by editing /etc/X11/xorg.conf in the Screen section on the Virtual line. Example:

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Virtual 2880 2880
    EndSubSection
EndSection

helpful information on the virtual screen at this link

At the link it says making the virtual screen square makes rotation easy. By setting it to 2880 x 2880 I was able to get both 1440 x 900 monitors into portrait mode using the System > Preferences > Monitors tool. Unfortunately after getting into this mode, paring back to the minimum such as 1800 x 1440 (assuming side by side portrait 900 x 1440) and rebooting resulted in an error message. The reverse ordering of dimensions, 1440 x 1800, also resulted in an error. Leaving it at 2880 x 2880 seems wasteful but at least it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.