Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So... I can't run Tor from my terminal. I have tried many different things, but I couldn't make it run. Once, it didn't stop to run when I wanted to. At my other attempt I also ended up failing because when it stopped to run I couldn't connect myself to the Internet. I hope you can help me here guys.

To be more specific, what I mean by "can't run from terminal" is that I can't hide my IP if I'm installing a program from terminal, for instance. Or if I'm running another program that is making a connection with the internet, my IP isn't being hidden. What I want is to make Tor work for all my programs. So my IP would be hidden in any connection with the internet.

share|improve this question
Could be a bit more specific about the program you are using and what it means when you are writing "hide your IP from terminal"? It would be nice to see the command you are using and the output. You can hide all sensitive aspects, if you want. – qbi Jan 10 '13 at 12:11

In order to run tor with all the connections you need to configure tor and polipo. See TOR check failed though Vidalia shows green onion for configuring tor and polipo. Basically what you need to do is configure manual proxy in your network settings and apply it system wide after that. I guess that will work.

enter image description here

share|improve this answer
OK... I'll try it. Thank you! = ) – user37504 Jan 6 '12 at 4:26
Hum... I tried it but that didn't work. I still can't hide my IP from terminal. However, now when I stop all services and put the proxy settings into "none" I still can connect to the internet and the fact that I was not able to that was really bothering me, so... THANK YOU VERY MUCH! = ) – user37504 Jan 6 '12 at 4:42
Did you try tor with specific programs and checked ? What do you get when you run a terminal command with usewithtor COMMAND ? – sagarchalise Jan 6 '12 at 5:01
I didn't know about that command... How do I use it? I typed it and it showed me this: "ERROR: COMMAND is setuid. usewithtor will not work on a setuid executable." – user37504 Jan 6 '12 at 5:24
Have you checked tor for firefox/chromium ? See here for more info: – sagarchalise Jan 6 '12 at 5:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.