Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am installing qt mobility tool kit but it shows an error message.how to fix it

1.2.0/src/multimedia' make[2]: Warning: File Makefile' has modification time 1.1e+04 s in the future g++ -c -pipe -g -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_WEBKIT -DQT_SHARED -DQTM_PLUGIN_PATH=\"/home/aboobacker/Desktop/qt-mobility-opensource-src-1.2.0/install/plugins\" -DQT_MAKEDLL -DQT_BUILD_MULTIMEDIA_LIB -DHAS_ALSA -DQT_MULTIMEDIA_QMEDIAPLAYER -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4 -I../global -I. -Iaudio -Ivideo -Ieffects -I/usr/X11R6/include -I../../build/Debug/QtMultimediaKit/moc -o ../../build/Debug/QtMultimediaKit/qaudiodevicefactory.o audio/qaudiodevicefactory.cpp In file included from audio/qaudiodevicefactory.cpp:60:0: audio/qaudiodeviceinfo_alsa_p.h:57:28: fatal error: alsa/asoundlib.h: No such file or directory compilation terminated. make[2]: * [../../build/Debug/QtMultimediaKit/qaudiodevicefactory.o] Error 1 make[2]: Leaving directory/home/aboobacker/Desktop/qt-mobility-opensource-src-1.2.0/src/multimedia' make[1]: * [sub-multimedia-make_default] Error 2 make[1]: Leaving directory `/home/aboobacker/Desktop/qt-mobility-opensource-src-1.2.0/src' make: * [sub-src-make_default-ordered] Error 2 aboobacker@aboobacker-desktop:~/Desktop/qt-mobility-opensource-src-1.2.0$ how to solve this?

share|improve this question
add comment

1 Answer 1

To compile packages you need to install the dependencies, including the headers, or -dev packages. Try

sudo apt-get install libasound2-dev

Check the dependencies listed in any README included with the source code (more likely then not you will have more dependencies to install).

share|improve this answer
    
linux/qsysteminfo_linux_common.cpp:78:35: fatal error: X11/extensions/Xrandr.h: No such file or directory compilation terminated. this is the next error how to fix this? –  Tachyons Jan 7 '12 at 3:20
    
When compiling from source, you need to install all the dependencies first. The dependencies are usually listed in the README file, and you also need the dependency-dev package, as with libasound2-dev. –  bodhi.zazen Jan 7 '12 at 3:57
    
sorry readme file does not include dependencies –  Tachyons Jan 7 '12 at 14:19
    
cd /tmp/%DISTNAME% ./configure -prefix $TARGET_DIR –  Tachyons Jan 7 '12 at 14:20
    
make To install the libraries and tools to $TARGET_DIR, type: make install If you have specified an install directory with root ownership, you will need to type: su -c "make install" or sudo make install –  Tachyons Jan 7 '12 at 14:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.