Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 11.10 (amd64) and I'm trying to get my infrared remote control working.

The IR device is a part of a DVB-T USB stick (Based on a RTL2832u chip). I'm using these drivers - it's the only way of getting this device to work under 11.10 that I found. It's a big impromevent from previous Ubuntu version, where I had to edit the driver's code.

The device works quite great - and the IR part of it works, too. The driver's page says that the code it's in alpha stage, but I'm pretty sure that my issue has nothing to do with that.

If, and only if driver's module is loaded with parameter rtl2832u_rc_mode=2 (which means "use NEC protocol for IR") the remote kind of works, I can see this by running cat /dev/.. ../input6 - when I press a button, random letters appear. The remote works just like a keyboard, but keys are totally messed up - when I press '5' the volume goes down, etc.

I would like to use Lirc to fix that, but Lirc can't detect my device (i.e. irw shows nothing). I suspect, it's because something gets into control of the device and sets it up as a keyboard. Lirc seems to be working, it's KDE settings module works too, but it just doesn't detect the device.

The Lirc page describes this issue, but since 2009 - the last year when that page was updated, Ubuntu moved from HAL (described there) to DeviceKit, rendering provided instruction useless.

I had a similar issue with my previous remote, but the keys were not messed up so much - the remote was usable, so I gave up trying to get Lirc working. I tried the answer provided here, but it changed nothing.

I also tried forcing lircd to use my device, but this didn't work too:

for i in /sys/class/input/input* ; do echo -n "$(basename "$i"): "; cat "$i/name"; done

shows

input0: Power Button
input1: Power Button
input2: Logitech Logitech USB Keyboard
input3: A4Tech PS/2+USB Mouse
input6: IR-receiver inside an USB DVB receiver

But when I run:

lircd -n --device=name='IR*' as root (also tried with the full name) I always see:

lircd-0.9.0[3983]: lircd(default) ready, using /var/run/lirc/lircd
lircd-0.9.0[3983]: accepted new client on /var/run/lirc/lircd
lircd-0.9.0[3983]: could not get file information for name=IR*
lircd-0.9.0[3983]: default_init(): No such file or directory
lircd-0.9.0[3983]: Failed to initialize hardware

So, how to set up Lirc with devinput driver in such case?

share|improve this question
    
Can you post exactly what did you do to make the remote work, i have the same dvb-t chip usb card with no luck around the remote. Tnx, Igor –  user104159 Nov 3 '12 at 10:35
    
@user104159: Make sure that you are forcing rc_mode to 2 (by using module parameter rtl2832u_rc_mode=2 when loading module. –  user1234567 Nov 5 '12 at 13:29

2 Answers 2

up vote 5 down vote accepted

I just now solved it.

lircd -n --device=name='IR*' -H devinput.

That's it. Works.

share|improve this answer

Tnx for reply. I loaded the module with modprobe dvb_usb_rtl2832u rc_mode=2 I have IR-receiver on input4. Started lircd with

lircd -n --device=name='IR*' -H devinput

but no luck with the remote. I also followed instructions on http://www.pclinuxos.com/forum/index.php?topic=89669.5;wap2

cat /proc/bus/input/devices | grep -n10 c803

gives IR-receiver on event4. Edited /etc/lirc/hardware.conf added DRIVER="devinput" and DEVICE=/dev/input/event4

started:

irrecord -H dev/input -f -d /dev/input/event4 ~/lircd.conf

but no life signs from the remote. I am using lubuntu 12.04 and Lifeview dvb-t Deluxe usb TV card Any ideas?

share|improve this answer
    
First, make sure that before you load the module with modprobe it's not loaded (rmmod it if it is). Also, make sure that your remote is physically working. I know it's obvious, but anyone can overlook such things. –  user1234567 Nov 10 '12 at 23:09
1  
Tnx, i did it. There was a faulty command modprobe dvb_usb_rtl2832u rc_mode=2. I put rtl2832u_rc_mode=2 behind modprobe dvb_usb_rtl2832u, like you said and now it works. Tnx, again, all i need now is to remap keys –  user104159 Nov 11 '12 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.