Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an external hdd with 3 partitions - 2 ntfs and 1 fat32 file systems. In linux I made folder in one of ntfs partitions, downloaded some stuff, and wanted to access through Win7; but windows can't SEE those folders. Other folders are still there. How can I access those folders made by linux? BTW, I use Ubuntu 11.10 with gnome and Windows 7

(320GB is my external hdd).

sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xbe2dbe2d
Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848    61646847    30720000    7  HPFS/NTFS/exFAT
/dev/sda3        61646848   225486847    81920000    7  HPFS/NTFS/exFAT
/dev/sda4       225488894   312580095    43545601    5  Extended
/dev/sda5       225488896   233299967     3905536   82  Linux swap / Solaris
/dev/sda6       233302016   312580095    39639040   83  Linux

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.
Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x73696d20

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1              63    65529134    32764536    b  W95 FAT32
/dev/sdb2        65529135   625137344   279804105    f  W95 Ext'd (LBA)
/dev/sdb5        65529198   270325754   102398278+   7  HPFS/NTFS/exFAT
/dev/sdb6       270325818   625137344   177405763+   7  HPFS/NTFS/exFAT

cat /etc/mtab

/dev/sda6 / ext4 rw,errors=remount-ro,user_xattr,commit=0 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/vindzigelskiu/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=vindzigelskiu 0 0
/dev/sdb1 /media/1D06-2AB4 vfat rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelpe    r=udisks 0 0
/dev/sdb5 /media/Adata\04097GB fuseblk rw,nosuid,nodev,allow_other,blksize=4096,default_permissions 0 0
/dev/sdb6 /media/Adata\040169GB fuseblk rw,nosuid,nodev,allow_other,blksize=4096,default_permissions 0 0
share|improve this question
i would recommend running 'sync' before unmounting ntfs partitions. it could be a delayed write failure. – RobotHumans Jan 5 '12 at 16:29
Did you create the NTFS (and the FAT) partitions using Linux or Windows? – Bruno Pereira Jan 5 '12 at 16:53
@BrunoPereira I created in win7 (using partition magic, I think). Normally I create partitions using ubuntu, but this time I needed to to this in Windows, because one partition (32gb fat32) is made for X360, so partition for microsoft by microsoft. Partitioning through linux, made partition unavailible in Xbox (even it was fat32). – PooLaS Jan 5 '12 at 17:03
up vote 0 down vote accepted

Firstly, can you reproduce?

Run these commands in a terminal:

umount /dev/sdb5
mount /dev/sdb5 -t ntfs /mnt
echo "hello world" > /mnt/bar0.txt
mkdir /mnt/foo
echo "hello world" > /mnt/foo/bar1.txt
umount /mnt

Now boot into windows.

  1. Can you open file bar0.txt?
  2. Can you open folder foo?
  3. Can you open file bar1.txt from inside folder foo?

If you can't reproduce

Something went fubar during your original operation. Try reproducing with your original dataset. If you still can't reproduce, chalk it up to an anomaly until you can. That is to say, there isn't enough evidence to say what went wrong. If you're curious, try breaking it. Deliberately do things wrong until your actions reproduce the problem. Maybe the problem only manifests when the ntfs needs checking..

If you can reproduce

Gather logs. Look in /var/log for anything interesting, and especially dmesg. Pinpoint when/where the error happens. Is it when you create a file? Is it when you create a folder? Is it when you create a file in a folder? Is it when you don't run sync before umounting? Is it when you interrupt a large copy leaving broken files?

Secondly, some thoughts

  1. Do the folders exist? When you boot back into linux, can you see the folders in question?

  2. Are the folder names weird? There are a number of characters windows can't use in file names.

  3. Does linux have the reverse problem? If you create a new folder in windows, can you see it in linux?

share|improve this answer
0. I tried to reproduce doing what you suggested, but this time, windows recognized files and folders. 1.Folders, which I can't see in windows, still exist, when I reboot linux or go back from windows. 2. No, I tried even change names to one word, but it didn't help. 3. Looks like no. I can see all files in linux. – PooLaS Jan 12 '12 at 17:01
@PooLaS sounds like your problem is an anomaly. Try deleting and recreating the original problem data set following the model I laid out. – djeikyb Jan 12 '12 at 22:03
I created new folder, put there all files from that bad folder, entered sync command in terminal before removing device and - wolia! it works. Windows can see that new folder with all files. Thanks, man – PooLaS Jan 13 '12 at 17:36
@PooLaS Sweet deal. It's pretty weird if manually running sync is required..umount should take care of everything. Might be a bug there if you can track it down. – djeikyb Jan 13 '12 at 22:54

I found a work around: attach the HDD to the windows machine create the folder there then put all of your sub folders into it. Annoying but you can access the sub folders.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.