Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a folder with a number of files, among them a .tex (latex) file that I'm working on. While I'm working on this file Ubuntu One gets an older version from the web and puts it locally - and I lose my work!

This has happened quite a few times and I'm about to remove Ubuntu One from my laptop. Nobody else is updating this file anywhere else (as a matter of fact at the present I only have one laptop sync to the web, the one I work on). I'm running it on Ubuntu 11.10, and this file gets saved often locally.

What should I do to avoid the above issue?

share|improve this question
    
What program are you using to edit your latex files? –  Bruno Pereira Jan 5 '12 at 16:24
    
i'm using texmaker –  user40637 Jan 5 '12 at 18:13

1 Answer 1

up vote 2 down vote accepted

You need to turn off the auto reload file when external changes are detected in texmaker.

What I am guessing that is happening is that UbuntuOne re-writes the file for some reason and texmaker detects that reloading the just synchronized file back to its original state before saves.

At the moment texmaker does not have the option to ask you what to do when it detects an external change and just reloads the file. Turn it off for now until that option is implemented.

That should allow you to edit your files without reverting changes on detect using UbuntuOne.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.