Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently installed Ubuntu 10.04LTS -Lucid Lynx on a dell Inspiron 1018 that came with windows 7 Starter.However my wifi is not working, I found the rfkill list command and on inputting I got the message dell wifi-soft blocked NO, Hardblocked Yes,notable is the fact that although I can see the bluetooth logo on the task bar i can also see that bluetooth also says blocked

share|improve this question
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Jan 7 '12 at 19:27
please put the complete terminal output into your question: rfkill list all & sudo lshw -class network – fossfreedom Jan 10 '12 at 13:09

Had a similar problem with an Inspiron 1018, where wireless stopped working. What fixed it for me was to boot into Windows and re-enable wireless (F2 button) from there. Discovered later that it could be also re-enabled from the BIOS by doing a factory reset there, in case you've removed W7 altogether. Just making sure the BIOS claimed wireless was on was not enough.

share|improve this answer
Thank you Simon ,I checked and performed a factory reset and voila, it worked .Thank you – James Ambole Feb 1 '12 at 8:04
Thank you. .... – chris Jun 6 '12 at 22:00

i had the same problem after installing ubuntu 11.10 on my hp touchsmart. anyway all you have to do is to connect you laptop to internet using ethernet cable, when connected to internet: go to system settings>additional drivers then select ur wireless adaptor and click activate, wait till it downloads and installs the driver software then restart ur machine and u're good to go. it worked for me i hope it works for u too.

share|improve this answer
Thank you , bios rest worked – James Ambole Feb 1 '12 at 8:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.