Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Through Virtualbox didn't allow me use USB because my account wasn't a vboxuser group, I've to run this command:

$sudo usermod -G vboxusers brallan

After I needed to access to superuser privileges and wasn't impossible. I'm the only user in my computer and simply I can't have administrator permission. What can I do?

Thanks!

PD.: when I try to use $sudo <command> I obtain this: brallan is not in the sudoers file. This incident will be reported. It's IMPOSSIBLE to use sudo command.

share|improve this question
    
    
Sorry, but my problem isn't with Virtualbox, is my account. I am the administrator but I don't have access to superuser. I suppose this command delete my superuser privileges. I want to recover it. –  Brallan Aguilar Jan 5 '12 at 5:54
1  
Yes you moved your user out of the admin group i presume you were suppose to type this command: sudo usermod -a -G vboxusers , notice the -a. –  Uri Herrera Jan 5 '12 at 5:58
    
askubuntu.com/questions/92832/have-put-me-out-of-admin Look here instead. –  Uri Herrera Jan 5 '12 at 5:58
    
That's true. And now? XD –  Brallan Aguilar Jan 5 '12 at 5:59

1 Answer 1

up vote 1 down vote accepted

In virtual box, right click your virtual machine and go to settings. Change settings to use the host's CD drive and enable boot from CD. Now insert Ubuntu live CD in your disk drive and start your virtual machine. It would boot from the CD/DVD and start live Ubuntu session. Mount your virtual harddisk and edit the sudoers file on the virtual harddisk. So if you mounted the virtual HD to /mnt/vhdd then the sudoers file will be at /mnt/vhdd/etc/sudoers. Edit this file and add the following line to its end

brallan     ALL=(ALL) ALL

Save this file and shutdown the virtual machine. Remove the CD from the drive and start the virtual machine. Things should be back to normal now and you should now have sudo rights for everything.

UPDATE:
Sorry but I missunderstood the question. I thought the problem was with guest OS and not host. For host computer you can boot your computer from live CD and follow the same steps i.e mount your hdd and edit sudoers file and add the above mentioned line to to it to grant user brallan sudo rights.

share|improve this answer
    
@enzotib well then he should do the same for host i.e boot from live cd and grant brallan sudo access. not very difficult to translate these steps to host, is it? –  binW Jan 5 '12 at 8:21
    
Excellent! I've the power again XD. Thank you very much. –  Brallan Aguilar Jan 5 '12 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.