Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Have put me out of admin

Updatet: Ubuntu 11.10 64bit. Error while logging in: Cannot update /home/marek/.ICEauthority .In the meantime i can work in terminal as sudo with ctrl+alt+F1 and know, that the file has no rights for the admin-group, only for me as admin marek. So this right has to be set. Also i don´t know the command to start from terminal the graphic-destop and must break down the system to go back.

share|improve this question

marked as duplicate by Marco Ceppi Jan 6 '12 at 13:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 0 down vote accepted

If the problem is permissions, you can do sudo chown -R marek:marek /home/marek, in case you've changed ownership somehow. In order to give yourself the required permissions, you can do sudo chmod -R u+rw /home/marek. That will attempt to give you read and write permissions on all files and folders in your home. Of course, this all assumes that your username is marek and that your home is /home/marek.

share|improve this answer
    
Thanks, i am back. The 2. one worked. Problem was, that i could not change anything while not logged as admin. Have tried to do the same with gparted and filemanager, but there the group has numbers, which i don´t know. What i don´t understand is, that for marek as owner of .ICE.. rw was shown, but not for the admin-group. Now i have given me all rights and this works,but still i have had them before or the button is misworking. –  Marek Jan 4 '12 at 23:33
    
I have looked, now the admin group can rw. But why, when i only gave me the rights? Do you know the command to start the graphic destop from the terminal? –  Marek Jan 4 '12 at 23:48
    
startx will load your desktop, but make sure not to run it with sudo, or else you'll run it as root. It is important not to use sudo when you don't need to. What do you mean the admin group can rw? You can. Can others in the admin group also? –  Jo-Erlend Schinstad Jan 5 '12 at 6:54
    
Thanks, this was it with suse, didn´t know,that ubuntu has also x-destop. The attributes of .ICEauthority were user marek rw, group: button admin - ;no login possible. Now it is admin rw and i can login as before. I have only tried to create a user root, was not allowed and so stopped. The question is, why get the group admin rw back, when admin marek(me) get, what he has had before, rw? Under users acount i could ever change to me as admin and create a new user. –  Marek Jan 5 '12 at 21:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.