Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded the Python 2.7 MSI installer for Windows and proceeded to install it with Wine. It worked without any problems.

However, running wine python.exe leads to a whole bunch of these errors:

fixme:msvcrt:MSVCRT__sopen : pmode 0x81b6 ignored

The application technically works, but is very hard to use because of these error messages. (They come up multiple times while the program is running.)

Is there a way to tell Wine to ignore these messages?

share|improve this question
I can't be the only one wondering why you'd want to run Python through Wine... – 8128 Oct 25 '10 at 8:01
@flute: Because the app needs to be cross-platform and I don't want to boot Windows just to test it. – Nathan Osman Oct 26 '10 at 1:32
I've been there. And have changed to VirtualBox. Testing is way more reliable. – Javier Rivera Oct 26 '10 at 6:52
@Javier: But I actually got it working :P – Nathan Osman Oct 26 '10 at 18:01
I should note that I ended up with Python 2.6 and not 2.7 - not a big problem, of course. – Nathan Osman Oct 26 '10 at 20:31
up vote 3 down vote accepted

You can have a lot of control on the wine error output, to turn off all the fixme, just run:

WINEDEBUG=fixme-all wine python.exe program

You can read the wine man page to find all the possible options.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.