Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I added this to /etc/samba/smb.conf.

[iTunes]
path = /home/myusername/iTunes
valid users = myusername
writable = yes

This has the desired effect, except that for some reason I can't edit file attributes:

Access Denied Not Found

I'm assuming this is because I need to add a certain setting to my configuration. How do I grant the necessary permissions to myusername?

share|improve this question
    
Can we see the rest of your smb.conf please –  benwh Jan 7 '12 at 13:23
    
It's pretty much the default configuration with that one share added at the bottom. pastebin.com/50h8jy4n –  Pieter Jan 7 '12 at 14:53
    
Ok, can you pastebin the contents of your samba log, it'll be /var/log/samba/log.xxxx where xxxx is the hostname of the client –  benwh Jan 8 '12 at 0:44
    
I think this is the relevant part: pastebin.com/i7aVzS84 –  Pieter Jan 9 '12 at 18:22
add comment

3 Answers 3

up vote 2 down vote accepted

I found the solution to my problem. It turns out the problem isn't related to Samba after all. Sorry. :)

How to Fix a Locked iTunes Library File -- http://www.ihackintosh.com/2010/01/how-to-fix-a-locked-itunes-library-file-2/

I've paraphrased the answer here by request:

  • Make sure iTunes is closed.
  • Go to your iTunes folder and move the iTunes Library file to your desktop. (You might want to create a backup of all the files in the main folder if you're worried you're gonna lose data.)
  • Launch iTunes. Your library should be empty.
  • Restore your library by dragging the iTunes Library file from your desktop into the iTunes window. In the iTunes window that pops up, click Replace.
share|improve this answer
add comment

Why don't you try from nautilus graphical interface for sharing? You can found sharing option to right click on an item in nautilus.

enter image description here

When you check on "Allow others to create and delete files in this folder" then anyone can edit and delete files in network but they need to know your samba username and password.

When anyone try to access your content he/she will be asked for your samba username and password. If he/she know the authentication information then he/she can see,edit and delete your content you share.

If you uncheck "Allow others....." then other (who knows authentication info) only see and copy the content but can not create or delete content.

If you want that Any one in the network can see your content the check the "Guest access ..." option. Where anyone can see the file without knowing your authentication information.

Add samba user in this file:

sudo gedit /etc/samba/smbusers

Format is = . So you can map your ubuntu username with different username for samba but this is not necessary. Example: say, your username is abc then add this line to /etc/samba/smbusers

<abc> = "<abc>"

Thats means anyone can access with abc username. you can use different name on right side.

Now set password for samba abc user (not your ubuntu user) password.

sudo smbpasswd -a username  [abc]
share|improve this answer
    
I'm specifically having a problem starting iTunes. It displays the following error when I try to start it: i.imgur.com/ksyXi.png That's why I thought that it's probably a file permission issue, even though I have read/write access. I tried your more user-friendly method as well, but I still get the same iTunes error. I know for sure that there is a way to make it work because it used to work when I was an openSUSE user. –  Pieter Jan 8 '12 at 19:43
    
did you try other player to play the file? Try another player to check that it is itunes or file problem. –  shantanu Jan 8 '12 at 21:34
    
I'm able to play music files in Windows over Samba. However, iTunes seems to have trouble accessing iTunes Libary.itl, which basically is its database of songs. –  Pieter Jan 9 '12 at 9:15
    
try to reinstall itunes. Delete all cache folder after uninstall then install again. –  shantanu Jan 10 '12 at 16:36
add comment

The writeable attributes are ReadOnly, Hidden, System and Archive.

Remember that these attributes are exclusive to Windows partitions (NTFS and maybe FAT). Because of this, as far as I know, it's not possible to store this attributes on a Linux server running Samba.

In Linux (ext2, ext3 and ext4 filesystems), the nearest equivalent to each property is:

ReadOnly: file permissions

Hidden: files that start with a period (.)

System: there is no near equivalent to this one. In Linux, the system files usually reside on specific folders (/bin, /etc, /usr, etc.) and have root as owner. So, there is no such concept of system attribute.

Archive: this attribute is used by backup software to make incremental backups and indicates that the file changed since last backup. In Linux, the change time can be used to this purpose (it can be checked using stat program)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.