Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I disable the tracking and display of recently opened files (and whatever else is remembered) in a default installation of Ubuntu? (This question originally concerned 11.10, but now that I'm on 12.04, that's the answer I've selected.)

(Note that this is not a duplicate of How can I keep recent files from appearing in Unity?, since that question and its answers are concerned with temporary and specific filtering. I want to disable it completely for a single user account.)


Okay, to deflect the inevitable and expand on my motivation...

While trawling the usual forums and Google results for a solution, it (unsurprisingly) seems that the near-universal use cases for this request are either browsing porn or Warhammer research. And the obvious solution to this is to create another user account to contain all evidence.

However, this is not why I'm asking, and I don't say that to get all high and mighty about it, it's because this answer won't help. (Even though I really don't have any interest in Warhammer, and I have no idea how that paint pot and brush ended up in my drawer, no that's not glue on my thumb, etc.)

My actual use case is that I use my personal laptop for presentations in different circles of my life. I have a user account set up with all the settings I like for presentations (shortcuts, small launcher, default associations, etc). But I don't want an accidental keystroke (or the find dialog) to display other recent presentations I've given, or the files I used in composing the presentation, or whatever. I also don't want to have to recreate this profile for every single presentation I might give. I just want a nice little isolated, memoryless, clean corner of my notebook for public display.

share|improve this question
2  
It's often helpful to say why you want things, since there can be better ways of accomplishing it, or things you'll loose that you weren't aware of, etc. –  Jo-Erlend Schinstad Jan 4 '12 at 11:30
    
@Jo-ErlendSchinstad - yes indeed, I was just editing for that purpose :) –  detly Jan 4 '12 at 11:33
    
You need to follow @jokerdino suggestion and use "All History" and click Delete. Now the history should not be shown in Unity –  Manish Sinha Mar 21 '12 at 6:41
    
@ManishSinha - yes, I'll try that when 12.04 is released and I'm prepared to use it. Until then, unless there's an answer for 11.10, I can't accept it. –  detly Mar 21 '12 at 7:38
1  
@ManishSinha - clearing history was not the issue, stopping all logging was. 0.8.0 didn't do that (despite appearances), but your recent updates to the Zeitgeist PPA seem to have fixed whatever problem was causing that. –  detly Mar 22 '12 at 0:43
show 8 more comments

5 Answers

up vote 46 down vote accepted

Go to System Settings and choose Privacy.

Then, turn off the button next to Record Activity. Now, your recent documents will no longer be logged by Zeitgeist.

System Settings Privacy Manager in Ubuntu 12.04

share|improve this answer
    
I'll have to wait until I'm ready to use 12.04. Hopefully they'll have fixed whatever issues Activity Monitor currently has. –  detly Feb 19 '12 at 9:57
    
Your instructions for 11.10 should include using the PPA mentioned by @Manish Sinha — following these instructions for the activity-log-manager available in the official repos was the first thing I tried, and it never worked. It only seems to work now with the updated libraries. –  detly Mar 22 '12 at 0:42
    
@detly I can't quite tell which PPA you used that helped you solve the problem. Perhaps, you can edit the answer and add that part yourself? –  jokerdino Mar 28 '12 at 9:23
    
Sorry, it doesn't actually seem to work after all. Also, what version of activity-log-manager do you have installed in that first screenshot? Mine has no "Recent items" tab, nor a "Delete history" button; just a "History" tab and a calendar based deletion that doesn't really work. –  detly Apr 2 '12 at 23:38
3  
Finally got to try it, and yes, it does work in 12.04 :) –  detly Sep 2 '12 at 7:06
show 8 more comments

I found this solution in the ubuntuforums at comment #3, but don't know if it works. Give it a try:

http://ubuntuforums.org/showthread.php?t=1860785

share|improve this answer
    
I've already tried the recently-used.xbel thing without success, but I'll try the Activity Monitor approach. –  detly Jan 4 '12 at 12:07
    
Hmm, disabling logging in the Activity Monitor doesn't seem to make any difference. (This is simply by clicking the big button at the bottom right of the dialog.) –  detly Jan 4 '12 at 13:34
add comment

for whatever documents you don't wish to see under the recent documents tab; do the following :

  1. Make sure you keep all such files in a folder.
  2. After accessing it every time, just rename the folder.

just by renaming the folder you will see the magic working :)

share|improve this answer
add comment

You can disable video recording at settings, privacy, files. You can also tell Ubuntu which folders shouldn't be recorded.

share|improve this answer
add comment

if you have upgraded to 12.10 already, do this:

go to: System Setting/Privacy/Files

then tick: Video and Image

check if it helps in case you still want your txt and docs activity to be available.

EDIT: Also, even better is to use the option "Don't record activity in the following folders:" what is the best customization I can see :), may be it is time to upgrade to 12.10 :D

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.