Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 64bit I tried to install my canon printer LBP2900 using several methods but the printer didn't work and I have this written in printer states : Idle - /usr/lib/cups/filter/pstocapt failed and when typing this command

 captstatusui -P LBP2900

this what i get :

(captstatusui:2432): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(captstatusui:2432): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(captstatusui:2432): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(captstatusui:2432): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

plesae help me

share|improve this question
    
Can you indiate whether you have 32 or 64 bit ubuntu and which installation instructions you have followed? –  Peter Smit Jan 4 '12 at 11:52
    
Maybe you tried this but Canon's download page for your printer's Linux drivers is here: software.canon-europe.com/products/0010177.asp Choose your OS & language. –  Tom Brossman Jan 4 '12 at 12:36

3 Answers 3

So you don't have Pixmap.......... Then install it using

sudo apt-get install pixmap

Also after install check

sudo /etc/init.d/ccpd status

when you see two numbers your printer is installed properly.......

Now take a test print........ if some error shows like,

Idle - /usr/lib/cups/filter/pstocapt

type Sudo nautalis type password for switching into root user. you will get a new browsing window with super user privillage

then copy the file named ccp from /usr/lib64/cups/backend to /usr/lib/cups/backend (if needed replace the ccp file in backend or keep as a backup with extension .bac)

Then copy the all files in /usr/lib64/cups/filter to /usr/lib/cups/filter

(similar way as above you can keep a backup if you want)

close the nautalis

Then test a print page......

and now your printer will work as you can see..

All the best from RJK

share|improve this answer
    
i installed pixmap as you told me and after inslall i checked ccpd status but there was only one number :Canon Printer Daemon for CUPS: ccpd: 1190 –  ayad mustafa Jan 9 '12 at 9:57
    
@ayadmustafa Restart the computer and again check the ccpd status. if it shows only one number. remove the installed files (using sudo apt-get remove cndrvcups-capt cndrvcups-common) and reinstall it. Then again check the status.... print the test page.. if not printing do as I told you in the above post.. and test ptint page... Enjoy printing:) –  rjkrocks Jan 10 '12 at 3:46

I think you should look at the official Ubuntu documentation on Canon LBPxxxx printers, that explains how to install and configure the official driver for them:

https://help.ubuntu.com/community/CanonCaptDrv190

If you are not able to make it work, here is a more complete guide on how to install them:

http://ubuntuforums.org/archive/index.php/t-1315665.html

And there is another perhaps easier method using a PPA, as explained here (ensure to modify the sources.list file in order to use the Natty repository, not the Oneiric):

http://www.benoitvidis.com/2011/11/install-a-canon-lbp7200cdn-printer-on-ubuntu-11-10-64bits/

share|improve this answer
    
Sorry, but that documentation is hopelessly incomplete... –  Peter Smit Jan 4 '12 at 11:00
    
Which problem have you encountered? –  heiko81 Jan 4 '12 at 11:06
    
See my answer. Also, for example, it does not use the --scripts flag on the alien command, while that is definetely neccessary. Also for earlier Ubuntu versions these instructions have not worked for me (see all my LBP 2900 questions here) –  Peter Smit Jan 4 '12 at 11:08
    
I edited my answer adding 2 new ways to install the driver. –  heiko81 Jan 4 '12 at 11:14

The fact that your printer is not working has nothing to do with the statusui. The Status UI is not necessary for printing, and works eventhough it gives this Gtk-WARNINGs.

The problem you have is that pstocapt doesn't work. Now you have not given much information about your system, but in my experience this happens on 64-bit machines.

In the case of 64-bit machines, the common installation procedure does something wrong. It makes symlinks in /usr/lib/cups/filter to files in /usr/lib64/cups/filter. This does not work. Therefore, you should do the following:

rm /usr/lib/cups/filter/pstocapt /usr/lib/cups/filter/pstocapt2 /usr/lib/cups/filter/pstocapt3 /usr/lib/cups/backend/ccp
cp /usr/lib64/filter/pstocapt* /usr/lib/cups/filter/
cp /usr/lib64/backend/ccp /usr/lib/cups/backend/

Off course, do this only if that files really exist in the lib64 folder.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.