Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When playing standard definition AVI files in VLC (and other media players) on my old Thinkpad T42 in Ubuntu 11.10, the playback is terrible: it's kinda slow and choppy - borderline unwatchable. Playing video in youtube is pretty much perfect. Can anyone help? Kind regards - Mike

share|improve this question
    
I had exactly the same problem, see my post link. The best I could do was to turn off the video overlay in vlc, which helped. –  Mark Williams Jan 4 '12 at 9:46
    
I have now changed to xubuntu, where everything works fine. VLC used to work well under Natty (with some video tearing). I wonder if it is all connected to the new graphic effects in Unity 2D. Maybe metacity has compositing turned on (which always screwed up videos in Natty). –  Mark Williams Jan 4 '12 at 9:50
    
You should post this as an answer, it can help another people. Your comments about using composition in metacity from another question (that links here) could be useful too. –  Javier Rivera Jan 4 '12 at 10:57
add comment

3 Answers

This could be to do with the X.org server working in EXA mode, as opposed to the older XAA mode, and compositing being enabled (by metacity probably). On my laptop, EXA mode (which is intended to make compositing better), causes video performance to suffer if compositing is on and videos to tear whether it is on or off. Under XAA, my videos playback smoothly without tearing and I don't have performance issues under compositing.

XAA is the traditional architecture and support for it is very stable. EXA is a newer acceleration architecture with better performance for the Render and Composite extensions. The default is EXA.

To test:

1) you can change the mode back to XAA (temporarily) by disabling Kernel Mode Setting (KMS) for the radeon module. Reboot, and press 'e' at the OS list in Grub. At the end of the 'LINUX=...' line add the string radeon.modeset=0 and press F10

2) you can also check metacity compositing is disabled (though if the above works, you don't need to). run gconf-editor /apps/metacity/general and uncheck the setting compositing_manager

If none of the above works, it may be a problem with video acceleration under 11.10. Try disabling video acceration (overlay) in the VLC video preferences. Or do what I did and switch to Xubuntu.

share|improve this answer
1  
Hi Mark. Disabling the overlay in VLC seems to have done trick - many thanks! I've found 11.10 more 'buggy' than previous iterations, but this was the only deal-breaker. Thanks again. –  Mike Roberts Jan 8 '12 at 1:55
    
In which case, do you want to mark the answer as correct? –  Mark Williams Jan 9 '12 at 10:03
add comment

I was also suffering from very jerky video playback on my Thinkpad T42, particularly at full-screen.

Rather than disabling KMS completely, you can switch from EXA to XAA by adding the following to the Devices section of your /etc/X11/xorg.conf, then restarting your computer:

Option    "AccelMethod"    "XAA"

If /etc/X11/xorg.conf doesn't exist, create it with the following:

Section "Device"
    Identifier    "Configured Video Device"
    Driver        "radeon"
    Option        "AccelMethod"    "XAA"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor       "Configured Monitor"
    Device        "Configured Video Device"
EndSection

This completely solved the issue for my T42 running Ubuntu 12.04.

share|improve this answer
add comment

Disabling KMS can also be done via /etc/modprobe.d -- on my Debian squeeze system, there is a radeon-kms.conf that can be modified to say:

options radeon modeset=0

this fixed video playback on my t42 nicely, and is a little easier (IMO) than modifying grub boot params

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.