Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu Maverick on my main PC, and I got the system configured just the way I like it (yay!) a long time ago. Everything was well until the recent Wine releases which are apparently made to use ALSA 1.0.24 which is sadly not available for Maverick. This means I lost all sound in Wine, which is not nearly as funny as it should be!

I found this tutorial on how to build ALSA 1.0.24, but I'm not sure if the procedure is "safe enough" to use. By "safe enough" I mean "will it mess up my system beyond repair". Is the big red-lettered disclaimer in the beginning of the article justified? How dangerous is the procedure described? Should I risk it and give it a shot or just bite the bullet and install Mint from scratch, like I did on my laptop (successfully, it seems)?

UPDATE:

After following Gilles' advice below about trying to install ALSA binaries for Lucid, I had a bit of a problem with sound being blocked for other apps when playing something in Flash. To fix this, I did the following:

Create /etc/asound.conf with the following content:

pcm.pulse { type pulse }
ctl.pulse { type pulse }
pcm.!default { type pulse }
ctl.!default { type pulse }

Then simply restart ALSA with the following command:

sudo alsa reload

I found all this on this forum thread but chose to restart ALSA instead of the whole system, and it worked!

share|improve this question

migrated from unix.stackexchange.com Jan 3 '12 at 23:29

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems..

1 Answer 1

up vote 2 down vote accepted

This warning is grossly exaggerated. The main problem with it is that it will install files under /lib and/usr, overwriting some files provided by the Ubuntu distribution. This means that it won't be easy to uninstall or upgrade your manually installed drivers. I recommend specifying ./configure --prefix=/usr/local when compiling the library and the utilities, so that everything you install that isn't part of the distribution is under /usr/local. For the drivers, you don't have this luxury: they must be under /lib/modules, but fortunately these aren't so critical.

Nonetheless, I suggest carefully reviewing and keeping note of what files are being installed. Run make -n install to see this, before running sudo make install. Alternatively, install the stow package, create a directory /usr/local/stow/alsa-1.0.24, give yourself write permission on it (e.g. sudo chown hannibal /usr/local/stow/alsa-1.0.24), specify ./configure --prefix=/usr/local/stow/alsa-1.0.24, and run make install without sudo. Then run sudo stow alsa-1.0.24 from the /usr/local/stow directory. Finally, symlink the modules under /usr/local/stow/alsa-1.0.24/lib/modules to the corresponding directory under /lib/modules and run sudo depmod -a.

Compiling the packages from the upstream source is not the easiest solution. There's a PPA with Alsa 1.0.24 packages for lucid; those binary packages might work on maverick. Or you could try recompiling the 1.0.24 packages from natty.

share|improve this answer
    
Thanks a lot for the detailed answer! Can you tell me how to try the binary packages for Lucid? Are .deb files installable if they are meant for a different version of Ubuntu? –  dr Hannibal Lecter Jan 4 '12 at 14:00
1  
@drHannibalLecter See the generic PPA installation instructions‌​. Packages don't contain an indication of what version of Ubuntu they're for; you can install them on another version if the dependencies are met (I haven't checked whether this is the case here). –  Gilles Jan 4 '12 at 21:01
    
It worked! I simply added the Lucid PPA and installed all the updates. I had no idea you can add PPAs for other versions.. Thanks, you saved my bacon! :) –  dr Hannibal Lecter Jan 6 '12 at 17:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.