Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't know what happened but all my archives have turned to read only mode. I can't extract my archives any more:

extract not working

This is an issue only on NTFS partitions, not home

enter image description here enter image description here
(The same archive could be extracted in my home folder) enter image description here

Also the "extract here" context menu option is missing:

context menu

What to do?

share|improve this question

It might be that your NTFS partitions are mounted read-only. This sometimes happens if the filesystem was not unmounted cleanly.

To check this, open a terminal and type:


Look for the NTFS partitions and see if they are mounted "ro" or "rw". "ro" indicates that they are read-only.

You can try remounting them rw:

sudo mount -o remount,rw [filesystem]

where "[filesystem]" is the NTFS filesystem in question.

It's likely that they will still not remount as read/write if they were improperly unmounted and are unchecked. In that case, you should reboot your system into Windows and run the disk checker from there. After that your partitions will be marked as clean and able to be mounted read/write again.

share|improve this answer
here is an image to that command – Black Block Jan 3 '12 at 19:14
@Naruto, that definitely shows that your NTFS partition is mounted read-only. You could try "sudo mount -o remount,rw /dev/sda9" to see if that does the trick, but I strongly suspect it will fail. If it does fail, you'll need to run checkdisk/scandisk on that drive from a Windows system. Ubuntu will not write to it as it could cause corruption if the filesystem is in an inconsistent state. – fader Jan 3 '12 at 19:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.