Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed the correct driver for my GeForce 6600 gt which is called x86. I had to run it through a ctrl-alt-f1 and stop x server. all went well, so i reboot and it looks like the driver is working (i had no drivers turned on when i ran this one), so all the open gl cairo dock was working well as usual and more. i downloaded hedgewars (worms) and flightgear, super choppy. AND trust me, its NOT my video card, they ran perfectly on pardus as well as HON. Did i not install the driver correctly? IF not PLEASE give me step by step instructions.

I enabled one of the proprietery drivers, rebooted, and now there is failure to boot, errors

Automatic crash report generation (FAIL) 
LightDm display manager (FAIL)

and it's unable to proceed, how do i disable all drivers within commands?

I haven't installed it using additional drivers, the default drivers that they gave me though, are incorrect. And I am unfamiliar with this program.

I disabled all of the proprietary drivers before i ran the install of the nvidia driver from the website, so the screen was glitchy and flickering (without driver) and then i ran the install through ctrl-alt-f1 and i rebooted after it said it was successful. And when it rebooted the screen was regular again and no flickers, but it doesn't run games

I still DON'T have the certified nvidia x86 driver under additional drivers.

share|improve this question

2 Answers 2

You should not install the drivers directly from nvidia.com as it's not fully compatible with Ubuntu. To recover from your mistake, uninstall the driver from nvidia.com first by opening a console and running:

sudo nvidia-installer --uninstall

Then reboot. If you still do not have your graphics effects back, open a console and run:

sudo apt-get --reinstall install libgl1-mesa-glx

To install the nvidia driver on Ubuntu, open the Additional Drivers program and choose the current driver.

share|improve this answer

Have you installed it using the program Additional driver, available under System Settings? This is the official program to use to install proprietary drivers in Ubuntu. It recognizes your video cards and suggests you the driver/s to install for your hardware, such as video card, wifi, etc.

share|improve this answer
    
no i havent installed it using additional drivers, the default drivers that they gave me though, are incorrect. And i am unfamiliar with this program –  Caleb Jan 3 '12 at 18:06
    
i downloaded and installed the nvidia driver, i was expecting it to "pop up" in the additional driver section, i dont know how to activate the driver i installed, i also dont know were to find it. –  Caleb Jan 3 '12 at 18:14
    
the odd thing is, i disabled all of the proprietary drivers before i ran the install of the nvidia driver from the website, so the screen was glitchy and flickering (without driver) and then i ran the intall through ctrl-alt-f1 and i rebooted after it said it was successful. And when it rebooted the screen was regular agin and no flickers, but it doesnt run games!?!? somethigns wrong –  Caleb Jan 3 '12 at 18:40
    
Try to install the driver from that program. When you open it, it will show the right driver for your Nvidia driver. Click on Activate and, after the end of the installation of the driver, it will ask you to reboot and then the driver will be installed. –  heiko81 Jan 3 '12 at 18:45
    
ill try all of the proprietary and ill let you know if any work, but i still DONT have the certified nvidia x86 driver under additional drivers. –  Caleb Jan 3 '12 at 18:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.