Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The problem is that when I play GTA: Vice City or San Andreas, for example, the computer may freeze. It happens randomly, I can play several times for half an hour a day and don't get the freeze and the next day I can get it easily. I tried running with the latest updates (OS, video driver and Wine) and without them on older versions of the stuff, but it doesn't matter: I get crashes in each case.

Running Ubuntu 11.10 Oneiric Ocelot, video card HIS Radeon HD4850 11.12 Catalyst, Wine 1.3.36 now.

In Catalyst everything is set to better performance, Catalyst AI - Advanced.

enter image description here

In Wine vertex shader is disabled to avoid a game bug (peds were too dark), 'window settings' are all checked, desktop size is 1920x1080 (maximum). There are two monitors, I'm playing on #1 only, they are set to mirror each other.

The computer seems to be fully hung up: Ctrl+Alt+Backspace or Ctrl+Alt+F1 don't work, but Alt+PrtScr+r,s,e,i,n,u,b combo reboots the computer.

share|improve this question

closed as off topic by Stefano Palazzo Feb 6 '12 at 16:25

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have the same problem playing spore with wine. I do this wine SporeApp.exe -safe and play with out any problem. But later on when I try to hibernate the computer it freezes. ubuntuforums.org/showthread.php?p=11586013 –  maniat1k Jan 4 '12 at 16:35
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 6 '12 at 15:42

2 Answers 2

My best guess is that the crash is probably graphics related, so you should try to run with another driver (the open-source driver - even though it is slower) to confirm this theory.

share|improve this answer
    
[fglrx] ASIC hang happened –  Nikita N Jan 4 '12 at 7:39
    
look for a newer or more stable version of fglrx, a quick google search shows that this bug has been reported - maybe a fix will be forthcoming –  totaam Jan 4 '12 at 9:10

In CCC (administrative):
-AntiAliansing set to override application setting, 2x
-Adaptive AntiAliansing set to override application setting, performance
-Antisotropic Filtering set to override application setting, 2x
-Mipmap Detail Level set to High Performance
-Vertical Refresh set to 'Always On'
-Catalyst AI enabled, standard
-Tearfree enabled

In Wine:
(1.3.36)
-Windows 7
-On graphics tab evertthing is checked, 800x600 virtual desktop, vertex shader: hardware, pixel shader enabled
-On audio tab all the devices are set manually

Playing with Skype and Pidgin on, and hasn't had crashes for 2 days of quite active playing the same game. Graphics driver is still the latest, catalyst 11.12. Ubuntu 11.10, 64-bit, with the latest updates (+ oneric-proposed).

I guess something changed in CCC helped, you can mark this question as resolved.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.