Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

I have Xubuntu 11.10. Today i installed ubuntu-desktop package to install Unity graphical environment. Unity 2d is working fine but 3d is not.

When i log in, I can hear the Ubuntu login sound and then the wallpaper loads for few seconds and then a black screen is shown. I could see still my mouse pointer though. Any ideas?

share|improve this question

marked as duplicate by jrg Feb 23 '12 at 13:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Welcome to AskUbuntu.com. Can you please give us more information about your graphics card and which drivers you are using? Add that to the question, it will be useful when trying to troubleshoot your issue. –  Bruno Pereira Jan 3 '12 at 13:10
1  
On Ask Ubuntu, instead of writing [SOLVED] in the title of the question, it is better to leave the title so, to upvote the best answer and to mark it as the right one. That's a green check mark. –  Agmenor Jan 23 '12 at 18:55
    
Thanks Agmenor! –  subeh.sharma Jan 24 '12 at 3:33

2 Answers 2

You can take a look at the Ubuntu official page about Unity and its requirements:

https://wiki.ubuntu.com/DemystifyingUnityGraphicsHardwareRequirements

You can try the following command to see if your video card and its driver support Unity 3D:

/usr/lib/nux/unity_support_test -p

share|improve this answer
    
Thanks. I've resolved it myself. I went to CCSM(while in UNity 2d) and 'enabled' Unity plugin. After that I logged out and log into Unity 3d. This time it worked! :-) –  subeh.sharma Jan 3 '12 at 17:07
    
But another problem has arose, I use dual-monitors so I need to disconnect the 2nd monitor before starting Unity and then connect it back otherwise Unity will not load and i get stuck on some blank screen. :-( –  subeh.sharma Jan 5 '12 at 11:39
1  
Maybe this is the bug you encountered: bugs.launchpad.net/ubuntu/+source/unity/+bug/894132 If so, mark it as affecting you. –  heiko81 Jan 5 '12 at 13:29
up vote 0 down vote accepted

Thanks. I've resolved it myself. I went to CCSM(while in UNity 2d) and 'enabled' Unity plugin. After that I logged out and log into Unity 3d. This time it worked! :-)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.