Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installing Ubuntu on this new machine i had various problems, so I asked around ask ubuntu for a solution. This is the latest one! :D When I start the pc it shows the temperature around 50-55. When I open chromium it shows 60+ (61,62,63). It even gets to 67-68 when multi-tasking 2 apps. The fan is working slightly louder than in windows 7. Talking about windows 7, the temperature is 45-50 when idle, 50-53 when working in browser. Im already loosing it with this machine. You can find specs here It says 'technishe daten' below the picture. Click that tab and you will reach the specs.

share|improve this question
add comment

2 Answers

You can try one of the two solutions suggested in this article, installing the latest version of Ati proprietary driver or the battery consumption indicator Jupiter:

http://cisight.com/install-amd-radeon-hd-6470m-and-solve-overheat-on-ubuntu-1110-oneiric/

share|improve this answer
    
when I followed this guide I couldn't boot (stuck on checking battery state...) but i fixed that and then when i boot i see everything but there are no effects like that fancy minimizing and so on... but when i was using default drivers with fresh install i had those (intel sandy bridge gpu) but it was heating, like stated above. –  vanjadjurdjevic Jan 3 '12 at 14:11
    
Someone solved the heat problem installing Jupiter, which allows you to choose between different battery consumption behaviours, so that you should minimize also the heating problem. –  heiko81 Jan 3 '12 at 14:18
add comment
up vote 2 down vote accepted

After some researching and refering to the above link posted by hekiko81 my status is as following : After using only hekiko81's solution the system would boot but without fancy 3d effects and when I 'fglrxinfo' to get details about current VGA i get the following :

  Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

So my conclusion is that ati drivers aren't properly installed.
This is error was due failed ATI proprietary drivers downloaded from official amd page. (Installed correctly). I thought then that using ATI drivers isn't the best idea since I have an integrated intel HD 3000 (sandy bridge) GPU (with ATI AMD Radeon HD 6470M). So I reinstalled ubuntu 11.10 and did the following to solve the problem :
1. I used Intel integrated drivers
since all eye candies worked well with integrated gpu i stuck with it (used default ubuntu open drivers)
2. Followed this guide from Ubuntu Forums
I used only 1. and 2. (a,b) in this tutorial :

1. Apply PCIE_ASPM

(Source: Phoronix)

As everyone suggested adding this for laptops to have longer battery life. I edited /etc/default/grub as

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1"

and then running

$ sudo update-grub

Note: I previously had added acpi_osi=Linux pci=noacpi (on worst condition of black screen), which I think is no more required, because the computer boots on to GUI without them. Above command enables power management, sandy bridge support (rc6) and frame buffer compression.<br/>

2. Apply Support for Hybrid Graphics

(Source: Linux Hybrid Graphics)

For those of you who don't have two graphics card this step is not required. In Ubuntu 11.04 I had bug while installing this, so I could not run vgaswitcheroo/switch

a. Install acpi_call
$ sudo apt-get install git
$ cd /tmp
$ git clone https://github.com/mkottman/acpi_call.git
$ cd acpi_call
$ make
$ sudo insmod acpi_call.ko
$ lscpi -vnnn | grep VGA # Check status here
$ ./test_off.sh # Check for any line that says "it works"
$ lspci -vnnn | grep VGA # Check with result of above

b. byo-switheroo (Unplug the ac-cord and see if it changes the battery life)

$ git clone https://github.com/awilliam/asus-switcheroo.git
$ cd asus-switcheroo
$ make
$ sudo make install-ubuntu
$ sudo su -
# cat /sys/kernel/debug/vgaswitcheroo/switch
# echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

It is temporary. If you have two graphics cards next time you boot, you will see both cards have Pwr set. If you want this to be permanent add the discrete card (e.g ati as blacklist). This settings will only enable the default intel card and disable other card. I haven't found yet a solution to flawlessly switch intel and ati cards. The better solution would be ati card using dedicated applications via catalyst control center.

$ sudo vi /etc/modprobe.d/blacklist.conf

Add a line at last

blacklist radeon

Then edit /etc/rc.local as
$ vi /etc/rc.local

Make the part after comments look like this

modprobe radeon
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

exit 0

3.Followed this guide
*Kudos to heiko81 ;)
Jupiter will show up in your notification bar. Click it and go to performance modes -> power saver, for lower temps.

4.Restart
Temperature will lower for sure, about 50 when idle and 55 when busy.
Conclusion (the Trick)
The trick was to utilize the following command

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

to lower the temperature of cpu and to slow down the fan. (to enable this permanently go back to step 2). When you enable this your GPU temperature reading will disappear (shows -128c) but when you restart it will measure GPU as usual.
BONUS
For measuring temperature I advise you to use XSensors (sudo apt-get install XSensors) and calibrate your sensors with sensors-detect
That is pretty it. Give me feedback on this solution, it worked for me on HP Pavilon g6, it gave me severe headache though. In the end my temperatures where 43-45 when idle; 48-55(60 when using much resources).


I took a few screenshots while writing this : My CPU temp fixed Core temps Gpu glitch after utilizing the command from conclusion section (the TRICK !!!)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.