Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not able to start QT Creator. When I start it the following error is given.

(qtcreator:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
(qtcreator:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
(qtcreator:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
(qtcreato:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Connected to accessibility bus at:  "unix:abstract=/tmp/dbus-Ih3kweFmKu,guid=af07d35df387caee7e8705270000001a" 
Registered DEC:  true 
Invalid parent:  0xa4f5b78 SharedTools::QtSingleApplication(0xbfee5be0, name = "qtcreator") 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
Requesting child objects for an interface that is a virtual child itself. 
QSpiAdaptor::getChild INVALID CHILD:  QWidget(0xa661398, name = "qt_scrollarea_viewport") 2 
ASSERT: "interface->childCount() == children.count()" in file adaptor.cpp, line 200
Aborted
share|improve this question
    
I think it's a problem with Qt installation. I installed Qt Creator from software center and it works well. –  ajantrik Jan 3 '12 at 9:20

2 Answers 2

I've found in Nokia developers forums that it is an issue with the Qt version shipped in Ubuntu. More precisely with the style plugin. Anyway, it seems there is a workaround. You should execute the installer with -style cleanlooks parameter.

./Qt_SDK_Lin64_offline_v1_1_4_en.run -style cleanlooks

share|improve this answer
    
can you please give exact commands –  coder Jan 3 '12 at 8:50
    
You are right. I think it's better now :) –  lafdez Jan 3 '12 at 9:44

There is something wrong with the qt-at-spi package (build with assertions ON?). Removing it solves the problem but may reduce accesibility features in other software.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.