Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu was working fine, then I moved my computer around, and when I brought it back, I now have two top panels like so:

Panel with window maximized

The smaller bottom panel still works somewhat, so it is not just a matter of it being drawn twice. It is a further a huge hassel as I can drag, for example, Google Chrome. Why is this happening and how can I fix it? Below, in this second image, you can see that the panel extends all the way down as well, creating a second wallpaper:

Desktop Only

The output of the command ps -ef | grep -i panel is

username    2084     1  0 12:24 ?        00:00:09 /usr/lib/unity/unity-panel-service
username    3821  3764  0 14:45 pts/0    00:00:00 grep --color=auto -i panel

Here is a list of things I have tried so far:

  1. Restarting
  2. Force restarting Unity (by activating/deactivating static application switcher in Compiz Config Utility)
  3. Changing desktop background (you never know!)

System Specs

OS : Ubuntu 11.10 CPU: AMD Phenom II X4 965 Processor Mem: 6 GB GPU: Radeon HD 4670

share|improve this question
    
obviously its a panel of some-sort... what is the output of ps -ef | grep -i panel ? should give an indication of what panel is being run –  fossfreedom Jan 2 '12 at 21:37
    
@fossfreedom I'll edit the output into the question –  puk Jan 2 '12 at 22:45
    
well that's just bizarre ... +1 for a good question. The output didnt reveal any panels other than standard unity. Have you installed anything extra lately? XFCE related, gnome-panel, gnome-shell etc, etc? –  fossfreedom Jan 2 '12 at 22:51
    
No, I didn't even use ubuntu while it was in the new location. The only other thing I can say is that I have a dual monitor set up, but that was there before as well. Oh also, I have already tried restarting –  puk Jan 2 '12 at 23:01
    
Which is your video card? Can you go to the settings and disable one of the two monitors? –  desgua Jan 3 '12 at 1:24

1 Answer 1

up vote 1 down vote accepted

On advice from desgua I went to deactivate one of my monitors (via catalyst) and it displayed three monitors as being active. When I identified the monitors, it showed that I had monitors 2 and 3 set to my first and second monitor. My guess is that monitor 2 or 3 was occluding monitor 1. This might be one of those rare cases where a computer problem (not properly identifying the monitors) creates bizarre behaviour as opposed completely crashing the system.

In my case, I fixed it by removing the Display Port (DP) to DVI adapter. My guess is that since it was an active display port, it was confusing the video card into thinking there was a third monitor.

share|improve this answer
    
I'm glad it worked ;-) –  desgua Jan 3 '12 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.