Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just want to get some advices howto save energy on my new laptop. I already installed a kernel patch.

On the picture below you can see, that i got less minutes of time than percentage. Only Wireless Lan and Firefox was running, and the display was on the lowest level I'm able to switch to.

enter image description here

I have installed no graphic driver, because the system would break after it.

If I'm using Windows I got about 2-3 hours or more to browsing the web, or reading something.

Some Data:

  • Model:Acer Aspire 5750G
  • System: Ubuntu 11.10 Oneric Ocelot x64
  • Kernel: 3.0.0-13.22 mjgaspmfix
  • DE: Gnome 3
  • CPU: Intel i7 2630QM (Sandy Bridge)
  • GPU: Nvidia Geforce GT 540M (Optimus)
share|improve this question
add comment

3 Answers

Here is your nvidia dirver link : http://www.nvidia.com/object/linux-display-amd64-290.10-driver.html

Install jupiter which is a indicator-applet. You can select your processor frequency [powersaver, performance, on demand) using jupiter.

Check the original backup time (not from applet). If backup time is ok then don't worry about notified time limit.

Most of the time graphics is the issue for more power consumption. So fix it first.

You have to install nvidia driver from command line.

CLT+ALT+F1

Login

sudo /etc/init.d/lightdm stop
sudo ./nvidi....
sudo /etc/init.d/lightdm start
share|improve this answer
    
After installing that driver I'm not able to start lightdm anymore. (after x-config is updated) I will try it on an fresh installed system. –  user40274 Jan 2 '12 at 21:59
    
what happen after restart? If you failed to start X window then start your ubuntu with recovery mode(second option on grub). Select root shell (last one). cd to your nvidia driver's backup directory(ei: cd /home/username/Desktop). uninstall nvidia (sudo ./nvidia.. --uninstall). next command is reboot –  shantanu Jan 3 '12 at 11:49
    
your Problem is your nvidia card. Try to fix the driver problem, power problem will automatically improve. install powertop which is a great apps to save laptop power. –  shantanu Jan 3 '12 at 11:53
    
I don't know why nvidia driver is not working. this nvidia.co.uk/object/linux-display-amd64-275.43-driver-uk.html is the latest driver for your model(notebook) See on "Supported Product tab" your model is listed there. I recommend to read README provided by nvidia to install driver. –  shantanu Jan 3 '12 at 11:59
add comment

Looking at powertop, I would guess that xfce uses less processor (and therefore less power) than Gnome Shell and Docky.

A better answer is probably to figure out CPU scaling. Web browsing shouldn't use a lot of your i7's power, so that should provide some improvements. Here's more about jupiter.

There's also powernap (which I've never used).

There may be some answers in this thread.

share|improve this answer
add comment

Your specific problem is probably the NVidia card drawing power, since you don't have any proper drivers. Installing those messes with Optimus, so that's out two. If you're open to slightly instable solutions, I can recommend Ironhide, available from this ppa: https://launchpad.net/~mj-casalogic/+archive/ironhide/ Note that the developer seems inactive, so don't expect any support. Ironhide is a solution that hacks hybrid graphics support through launching extra xorg sessions. In addition, it has a database with powersaving configurations. (I have a working configuration for the Asus K53SV, which has a GT540M, so chances are there's one for yours too.) Alternatively, there's Bumblebee, which is more stable but does not attempt to help you in powersaving, which is what your aim is. ( https://github.com/Bumblebee-Project/Bumblebee )

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.