Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I recompile the source to force the option to allow changing languages and keyboard layouts at login?

share|improve this question
    
Why don't use gdm instead of lightdm? –  enzotib Jan 2 '12 at 21:18
add comment

2 Answers

Did you install the language packs from Language support ?

Update

I seem to have mixed the keyboard layout with the language support!

There is a solution provided in a bug report: Comment #16:

There is now an optional language selector in the GTK greeter for desktops that require it. To enable it set show-language-selector=true in /etc/lightdm/lightdm-gtk-greeter.conf. Fixed in 0.9.8.

Solution

Execute this command:

gksu gedit /etc/lightdm/lightdm-gtk-greeter.conf

Find the line:

#show-language-selector=false

Change it to:

show-language-selector=true

Save and exit. Logout / Login or reboot the machine to apply the effect.

share|improve this answer
1  
Thanks for the rapid answer. If I got it right, that icon will only change the keyboard layout while I’m log in? I need the possibility to alter the system language after login. Using the old login screen, I just selected the user. After that, there was different options in the bottom of the screen. The leftmost icon was a globe followed by option to set the system language after login. If there is no equal option in the new login screen- how can I return to the old one? Best regards Bosch –  Bodozer Jul 2 '12 at 6:07
    
Could you test this solution please? Quoting comment #16: There is now an optional language selector in the GTK greeter for desktops that require it. To enable it set show-language-selector=true in /etc/lightdm/lightdm-gtk-greeter.conf. Fixed in 0.9.8. –  medigeek Jul 2 '12 at 9:27
add comment

You can explicitly turn on the language selector in the login screen according to this comment:

To enable it set show-language-selector=true in /etc/lightdm/lightdm-gtk-greeter.conf.

share|improve this answer
1  
I tried this on 12.04 and it is not working. –  Adi Roiban May 30 '12 at 9:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.