Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my first post here, I hope that you guys can help. I connected my USB on my computer (Ubuntu), but I can't modify its folders/files. It says that I don't have enough permission. So I tried changing the mod with the terminal using

sudo chmod 777 /media/< USB NAME > 

but it returns that it's read only. When I put my USB on another OS it's the same! Please help! I want to be able to modify my USB contents on any OS.

Sorry, I would like to post images, but don't have enough reputation... But I can tell that mine is different than yours, it shows a warning sign, but I can see that it said that I might need two softwares: dosfstools and mtools, should I get them?

share|improve this question
    
BTW: other USBs work fine, I am using Ubuntu 11.10. Than you. –  Troy Jan 2 '12 at 19:08
add comment

1 Answer

Open Gparted. Unmount your usb disk from gparted. Now repair your usb disk's partition.

[example: /dev/sdb1 not /dev/sdb. Repair partition not the disk].

enter image description here From partition menu(P) and select unmount. Again From partition menu select check. Now apply.

Reinsert your usb disk.

Follow the Instruction: [edited]

Step1: unmount your disk [sudo umount /media/usbdisk] mount it with write permission [ sudo mount -o remount,rw '/meida/usbdisk'] Now try to format the disk.[use disk utility]

Step2: [If first step does not work then follow the following steps]
Open disk utility. also insert your usb disk. Unmount the volume(m)

enter image description here

Now Delete the partition(D) enter image description here

Create a partition. Then mount it.

share|improve this answer
    
Hi Shantanu, thanks for your quick response, I understand the first part, I downloaded gparted, installed it, but when I try to unmount my device by right clicking, the unmount option wasn't enabled. –  Troy Jan 2 '12 at 19:21
    
if it is disable that means your usb is already unmounted. Select check and apply. –  shantanu Jan 2 '12 at 19:46
    
I tried to check it, but hereis what it says: An error occured while applying changes See the details for more information. IMPORTANT If you want support, you need to provide the saved details! See gparted.org/save-details.htm for more information –  Troy Jan 2 '12 at 19:58
    
can you access the file/folder of usb disk[just read]? Can you unmount your usb disk with right click? –  shantanu Jan 2 '12 at 20:04
    
Yes I can access it, I can read it, I can even add files or folders to it, But I can't delete things from it.......................... oops! Before posting this, I checked, I saw that I couldn't even open it anymore, I removed and reinserted it, and now it won't even show up... I guess that this gparted made my day worst... :( –  Troy Jan 2 '12 at 20:05
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.