Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to be able to connect to wireless networks and wired networks (although my wireless network had problems; see my other question). Then, one day, the section Wired Networks just disappeared! And when I plugin a cable, nothing happens! Why?

Despite having worked a while, the answer below seems to have stopped working for me. Therefore, my question is still active, and I anxiously await any replies.

share|improve this question
    
Can you add some hardware information to your question? askubuntu.com/questions/14008/… –  Jorge Castro Dec 26 '10 at 22:31
    
Any specifics? I'm not sure where to start, as I don't know what has changed in the meantime. –  Lyrositor Jan 1 '11 at 2:03
    
Anything in those log files that mention networking stuff, like the kind of hardware the network card is, etc. –  Jorge Castro Jan 25 '11 at 13:16
add comment

1 Answer

up vote 1 down vote accepted

Edit /etc/network/interfaces and make sure it looks like this:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0

It sounds like it's blocking network-manager from configuring the interface.

share|improve this answer
    
Perfect! That worked! Thanks a lot! –  Lyrositor Oct 24 '10 at 17:09
    
No, wait, it only worked a few hours and a few restarts. Four hours later, I booted up my computer to see that it was as before, and worse: this time, when I checked the file, auto eth0 was still there! So that means the problem lies elsewhere. –  Lyrositor Oct 24 '10 at 21:14
    
Hold on... It's back again. What the... –  Lyrositor Oct 25 '10 at 1:31
    
when i input the code it says permission denied –  user11417 Feb 24 '11 at 17:35
    
You have to have admin rights to edit the file. Use something like gksudo gedit /etc/network/interfaces –  Jonathon Feb 26 '11 at 11:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.