Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I noticed that time indicator on the top pane is not showing the date/time, but is just saying "Time" (see attached screenshot). Does anyone know why is that so? How can I fix it and make show the date/time back again?

Reinstalling indicator-datetime did not help.

enter image description here

share|improve this question

3 Answers 3

up vote 5 down vote accepted

It's likely that the indicator is misconfigured.

Try to click Time & Date settings in your screenshot, in the next window choose clock and play with those settings.

If this doesn't work try this command, it will change the potenciall most complicated of your clock settings to the defaults:

gsettings set com.canonical.indicator.datetime time-format locale-default
share|improve this answer

Can I suggest you right click the click and choose Time & Date Settings

Check that you have a valid location set (the field and the graphic point to your country and capital city etc).

Also check the next tab that the defaults are defined as per this image:

enter image description here

share|improve this answer

Use this command:

sudo dpkg-reconfigure --frontend noninteractive tzdata

From: Missing date & time from top panel of Unity Desktop

share|improve this answer
    
Thanks! This answer fixed it for me, when the others did not. –  B Johnson Apr 28 '12 at 8:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.