Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I was still using Natty with Compiz. I had noticed that disabling Vsync in Compiz made dragging windows much more smooth and responsive (I don't mind the tearing).

I installed Ocelot this morning which seems to use Mutter by default (I may be wrong there, I'm still kind of lost). Dragging windows has the same sluggish feeling as with Compiz and Vsync enabled. So I was thinking I could try disabling Vsync.

Can vsync be disabled/enabled in Mutter?

Edit to answer the comments:

$ ps -ef | grep compiz | grep $USER
<myname>  3989  3908  5 12:14 ?        00:03:38 compiz
<myname>  4051  3989  0 12:15 ?        00:00:00 /bin/sh -c /usr/bin/compiz-decorator
<myname> 15409 15406  0 13:25 pts/0    00:00:00 grep compiz

So indeed I was confused. If I'm running Compiz I should manage to bend it to my will.

share|improve this question
1  
First, let's find out if you're running Unity 2D or 3D. Please run this in a terminal and add the output to your question. ps -ef | grep compiz | grep $USER –  jrg Jan 2 '12 at 11:33
    
ummm - are you running gnome-shell or the unity interface? –  fossfreedom Jan 2 '12 at 11:35
1  
Unity uses compiz not mutter. –  Javier Rivera Jan 2 '12 at 11:43
    
@fossdreedom I'm using the unity interface. –  Niriel Jan 2 '12 at 12:29
    
@Javier Rivera Good to know. I got confused. –  Niriel Jan 2 '12 at 12:31
show 1 more comment

2 Answers 2

Thanks all,

Since you proved me I was running Compiz, I downloaded CompizConfig Settings Manager and disabled Vsync under the OpenGL tab. That did it.

share|improve this answer
add comment

There are two implementations of Unity in Ubuntu. The primary one uses Compiz and the "fallback" uses Metacity. Gnome Shell uses Mutter, but the "fallback" for Gnome Shell, which is the classic Ubuntu desktop (Gnome Panel) uses Metacity... It's easy to get a little confused these days. :)

share|improve this answer
    
Thanks for clearing things up! –  Niriel Jan 2 '12 at 12:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.