Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

friends please help me with this error when i try to mount the ntfs drive i getting an error like

enter image description here

for to mount the ntfs partitions i have to use the STORAGE DEVICE MANAGER every time any help to mount them in a usual(on mouse clicking) way of mounting the drives.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I tried to replicate your problem with my own ntfs partition, in fact i too didnt had the write permissions on the ntfs partition,

The answer to why you are not able to mount the ntfs parition with write permissions lies in the FUSE library.

In the screenshot which you have pasted, it says you are trying to mount a ntfs block device using FUSE library.

First check if you have fuse-utils package installed on your system, if not install the fuse-utils package using apt-get

Then, remove the following lines from your /etc/fstab

  /dev/sda2 /media/myMountPoint ntfs-3g quiet,defaults,rw 0 0

Now, we need to mount the ntfs block partition using fusermount command

Now, open the /etc/mtab with root priviliges, and add the following line

/dev/sda3 /media/D fuseblk rw,nosuid,nodev,allow_other,blksize=4096,default_permissions 0 0

replace with your partition and mount point and reboot the system.

Sorry for putting this in separate answer, i could not write all this as a comment. After the reboot, when i mounted my mountpoint, i was having write permissions, tell me if it works for you too.

share|improve this answer

The problem is NTFS paritions doesnt support unix file permissions, As you are accessing the Hard drive on a non NTFS operating system, it is not the NTFS protections that you need to concern yourself with.

In linux: open a terminal window and type in:

"gksudo nautilus"

This opens up a nautilus window where you have super-user privileges.

Browse to the relevant external hard-drive and open up the properties window and select the permissions tab.

Make yourself the owner and make sure that you have read and write privileges.

Also click on the tab labeled: "Apply permissions to enclosed files"

If the above procedure is not working for you then,

goto terminal and open the following file using any text editor you like

sudo vim /etc/fstab

add the following lines to the file

/dev/sda2 /media/myMountPoint ntfs-3g quiet,defaults,rw 0 0

replace /dev/sda2 with your partition and myMountPoint with your mount point.

The following partition will be automatically added in the next reboot.

share|improve this answer
    
sorry to say that i have tried them before but no use –  VENKI Jan 2 '12 at 12:49
    
change the entry in /etc/fstab to this and check again "/dev/sda2 /media/myMountPoint ntfs rw,users,youruserID,umask=00 0 0" replace youruserID with your user ID –  rao_555 Jan 2 '12 at 13:01
    
sorry no use i have checked those options also –  VENKI Jan 2 '12 at 13:23

try to mount the drive using root priviliges. try mounting the device using mount command

  sudo  mount /dev/sda1 /mnt/mydisk

replace /dev/sda1 with your device and /mnt/mydisk with your mount point.

share|improve this answer
    
yes i do can mount the drive but have read only permissions for that drive –  VENKI Jan 2 '12 at 12:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.