Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.04 32bit before with the Wubi installer.I therefore completely uninstalled ubuntu and downloaded the new Ubuntu 11.10 32bit.But now When I execute the Wubi.exe it doesn't start.I just get a quick change of the mouse pointer showing that something happened but then nothing , no error messages. Can anyone help me?

===== Summary of a discussion so far during the investigation:

are you absolutely sure you downloaded 32bit ubuntu 11.10? Are you sure you are using 32bit windows 7 and not 64bit windows? Did you do a md5sum checksum to confirm the ISO downloaded is valid and not corrupted?

hey i downloaded ubuntu-11.10-desktop-i386.iso & am sure about win7 32bit & iso image MD5 is : c396dd0f97bd122691bdb92d7e68fde5 i checked both hashes from ubuntu & mine both same

thats the desktop version... the MD5 sum looks ok. Did you use this webpage to download from? ubuntu.com/download/ubuntu/windows-installer

i download it from ubuntu.com/download/ubuntu/download full .iso image not only wubi

what happens if you start wubi.exe from a command line?

if i write start H:\wubi.exe in cmd ...nothing happened without quick change of the mouse pointer showing that something happened

is this a standard PC or a work-environment PC? i.e. you do have administrator rights or some-sort of clampdown on windows 7?

i am only user & administrator of my pc & it is a standard pc

share|improve this question
    
see .log file paste.ubuntu.com/790468 –  partho222 Jan 2 '12 at 12:55
add comment

3 Answers

up vote 2 down vote accepted

In one of my log files, I have:

09-28 19:48 DEBUG WindowsBackend: startup_folder=C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

Whereas you have:

01-03 01:13 DEBUG WindowsBackend: startup_folder=None

From analysis of the code, it appears that the bug is due to the fact that you don't have the startup folder set properly. To workaround this problem, set the startup environment variable by editing the registry (regedit) and make sure the following is set: 'HKEY_LOCAL_MACHINE', '\SOFTWARE\Microsoft\Windows\CurrentVersion' '\Explorer\Shell Folders', 'Common Startup'

And ensure the referenced folder exists i.e. C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

PS here is a reference to the bug report (this shouldn't be a fatal problem).

share|improve this answer
    
bug reported...& did every possible way but still no luck –  partho222 Jan 2 '12 at 19:22
add comment

at last problem solved.

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

accidentally this "startup" folder was deleted.just create this manually & wubi.exe runs.

09-28 19:48 DEBUG WindowsBackend: startup_folder=C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

01-03 01:13 DEBUG WindowsBackend: startup_folder=None

From analysis of the code, it appears that the bug is due to the fact that you don't have the startup folder set properly. To workaround this problem, set the startup environment variable by editing the registry (regedit) and make sure the following is set: 'HKEY_LOCAL_MACHINE', '\SOFTWARE\Microsoft\Windows\CurrentVersion' '\Explorer\Shell Folders', 'Common Startup'

I added a more detailed answer to the bug report including some code snippets.

thanks bcbc for your log it helps me a lot.

share|improve this answer
add comment

Create a new user account in windows7 with administrative power. If you can extract iso using winRar or zip then your iso is not corrupted. Extract your iso in anywhere. Right click on wubi.exe and select run as admin.

Must uninstall and delete ubuntu folder from windows (previous installed ubuntu). If anything does not work then download just wubi.exe for ubuntu 11.10. Keep disconnect your internet during installation.

share|improve this answer
    
i did everything you told but no luck.also only wubi.exe does not open (online or offline) –  partho222 Jan 2 '12 at 12:17
    
try another way. Don't extract iso. Mount it using ultraISO or iso mounter apps. Try to run wubi.exe from virtual drive. –  shantanu Jan 2 '12 at 19:07
    
already did it. –  partho222 Jan 2 '12 at 19:23
    
Can you test the iso in another windows 7 pc? Do not install but just test that wubi.exe run. –  shantanu Jan 2 '12 at 19:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.