Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  1. I installed Ubuntu 11.10 amd64 and it used the default settings and vga driver: unknown both screens sere working regardless of the errors of turning the laptop's off then both go off forever!
  2. So I tried installing Nvidia driver in both ways,I. From the additional drivers current-driver way and II. The manual:

sudo service lightdm stop
sudo sh Nvidia..._.run
sudo service lightdm start

Both had the same results,

in system info : Graphics : UNKNOWN , in display settings : one UNKNOWN display is detected "the laptop's" and **cannot detect my other display** 

What I did is that I modified the display's settings from Nvidia settings as a root in order to save the settings

sudo nvidia-settings
LG Display > enabled, res: 1920- 1080, 60hz, left of (separate display options)
Laptop Display > right of

Now the external screen can turn it's lights on but not useful at all I can't make it the default primary screen nor I can use it as primary if I disable the laptop's the other turns off along with it

I believe if the Graphics: unknown problem is solved then all is solved the system doesn't recognize the driver as if it is on it's own

Nvidia admins said it is a problem of the system not the driver

"it was working properly with Ubuntu 10. 04 with Nvidia manual driver installation"

Hardware info:
computer type: laptop, type: ASUS f8sn, CPU 2. 4 core 2 due T8300 santarosa penryn,
vga: Nvidia geforce 9500m gs, motherboard: ASUS, bus: Intel, chipset: Intel, external screen: LG E 2205, DVI connector: DVI-D Single link

I posted this after maybe the 15th reformat and reinstall of Ubuntu to fix this problem

share|improve this question
    
Please try this, I had the same problem with X64 and Nvidia graphic card, and finally got it to work with hardware acceleration and everything: ubuntuforums.org/showthread.php?t=1904230 –  Torsten Jan 4 '12 at 15:26
    
i'll check if it works better –  CME64 Jan 4 '12 at 16:35
add comment

closed as off-topic by searchfgold6789, mikewhatever, Eric Carvalho, Minato Namikaze, Braiam Apr 12 at 23:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

up vote 0 down vote accepted

I was playing around and i found a satisfying solution somehow ! though i still hate this system's bugs :( ;

the solution is

  1. to open nvidia settings as the root as i explained above

  2. then enable the external display and modify its properties and use it as (twin display) not (x separate) Important

  3. make it your own default by checking that option

  4. apply & save the settings over /etc/X11/xorg.conf

  5. turn your laptop's screen off and just use the external + restart and enjoy

#

vulnerabilities :

  1. your vga is working for 2 displays rather than for 1

  2. you cannot disable the laptop's display from the settings or you will lose sight of > both

  3. your mouse can go to the other display as an extension even if its lights are off (still considered there)

  4. Graphics will still be unknown in the system thus you can't use the display settings > from the system which means no rotation and no default settings on the system (likebooting up with one specific display on)

if there is a better solution please fill us in..

regards,,

share|improve this answer
add comment

I found the best solution to this problem

it is to switch back to ubuntu 10.04 the most stable version ever

now the desktop is working perfectly even with nvidia driver and settings because the system detects another manager for the display and prioritized the nvidia x settings over the os default display settings .

after you install nvidia driver, and open display settings, a prompt window will appear asking if you want to use nvidia settings or the os settings unlike 11.X which doesn't even know about the existence of another manager (nvidia x settings).

*of course to save the settings u will need to use the root permission

regards,

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.