Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason I can't open Catalyst with administrative privaleges on Xubuntu 11.10. The regular Catalyst Control Center works fine, but it doesn't allow me to make necessary changes to my multiple monitor configuration. Is there a way to open it through the terminal with a sudo command, or is there anything else I should be looking for?

I used the command the following command to open Catalyst with admin privilages:

sudo amdcccle

I get the same results with gksu.

It automatically configure my multiple monitors and placed one on top of the other, instead of side by side. It won't allow me to make any changes. Every time I try to hit the apply button, it closes without making any changes.

If I go to Display, in the Settings Manager, it doesn't give me the option to configure multiple desktops. However, the changes I make there do stick.

share|improve this question
    
Don't use Sudo with GUI applications use gksu.And yes it's a bug with the Catalyst Control Center. –  Uri Herrera Jan 2 '12 at 3:32
    
Thanks for the info. Unfortunately, I have the same results with gksu. –  Arthur Jan 2 '12 at 3:47
    
Does the same happen if you use XFCE's Display properties?. –  Uri Herrera Jan 2 '12 at 4:28
    
If I got to Display, in the Settings Manager, it doesn't give me the option to configure multiple desktops. However, the changes I make there do stick. –  Arthur Jan 2 '12 at 5:07
    
using gksudo amdcccle in the terminal works for me on Kubuntu. I have the same issue as the OP if I try any other method. –  MountainX Mar 16 '12 at 1:27
show 2 more comments

2 Answers

I got it working (on Xubuntu 12.04) using

sudo -s

and then as root run

amdcccle

Configuring in the AMD Catalyst resulted in a proper configuration at the login screen.

To get it working after login I had to change settings through the "Settings editor" then unfold "display" find the display you have on the right, unfold "position" and as x-position enter the x-resolution of your left display. This moves the image of the right display to the right. Log out and in again to see the result.

share|improve this answer
add comment
up vote 1 down vote accepted

I got it to work by installing Unity and changing it through the Unity window manager. Then logging back into XFCE. I wonder how many people have this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.