Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok. I wanted to see how 3D cube would look like with my 11.10, so I installed CCSM and turned on 3D cube and disabled expose (think that is what it is called). Then after that everything went sideways. I can get to the desktop but only see part of the top panel, no launcher, no indication area, just 'file' 'edit' 'view'...'help' alt+F2 does not work, the super key does not bring up the dash. Unity 2D works, but I rather Unity 3D. CCSM in 2D did not help. What can I do to restore Unity to before my fiddling with it? I tired ctrl+alt+F1 (to try some thing in terminal I saw for an answer to a question similar to mine) at the log in but i just got a black screen that was not responsive.

Thank you for your time and answers.

share|improve this question
    
Try some of the solutions listed in this answer: askubuntu.com/questions/80589/… and then edit your question if it doesn't work, thanks! –  Jorge Castro Jan 2 '12 at 1:56

3 Answers 3

up vote 1 down vote accepted

Ctrl+Alt+T should open the terminal. If that doesn't work, try logging in to Unity 2D (option from clicking on the cog at the login screen). From there run:

unity --reset

and failing that, try:

unity --replace

to completely restore Unity. (note: it doesn't show up well in my browser, but both the above codes had two consecutive dashes)

If you can live without the flashy graphics/interface and want a stable system then avoid CCSM like the plague until they sort it out. It seems to be causing nothing but trouble.

I literally just overcame this problem, not sure how long it will last though. Do your googling and you will find the solution - this page helped me:

http://sqizit.bartletts.id.au/2011/11/07/unity-launchersidebar-missing-on-ubuntu-11-10/

Best of luck.

Will

share|improve this answer
    
Thank you. will try this soon as I can, and will pretty sure by the looks of it will be accepting this once I can try it out. –  Dustin Jan 5 '12 at 15:18
    
amazing worked like a charm, thanks for the details and your time. –  Dustin Jan 6 '12 at 3:57

You might try using the following command in your terminal window:

unity --reset

Here is additional info:

http://www.webupd8.org/2011/04/how-to-reset-unity-launcher-icons-or.html

Good luck.

share|improve this answer
    
But how can I run terminal? I cannot activate the dash or see the launcher? –  Dustin Jan 2 '12 at 15:43

CCSM has been known to completely hose Unity/Compiz settings. It's relatively easy to recover from this.

This answer, has worked for me:

Just backup (rename) ~/.compiz-1 and ~/.config/compiz-1 directories and let them to be created again with the default settings. You'll then need to logout and log back in again.

mv ~/.compiz-1 ~/.compiz-1.BACKUP
mv ~/.config/compiz-1 ~/.config/compiz-1.BACKUP
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.