Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an .iso file which I would like to mount. I have made a folder in /mnt/iso as a mount point. Now I try:

sudo mount -o loop filename.iso /mnt/iso

and the reply is:

mount: you must specify the filesystem type

and the folder of /mnt/iso is empty. I have tried using

sudo mount -o loop -t ext4 filename.iso /mnt/iso

it says that mount: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error (and more text)...

I found the filesystem type from using df -T and mount at the command line.

What could be missing or wrong?

share|improve this question
1  
have you done an md5sum of the ISO to check that it is a valid ISO? –  fossfreedom Jan 1 '12 at 18:28
    
@fossfreedom, no I haven't, good idea, but I have no idea how, can you give me a hint? (is it possible that the .iso is faulty?) –  Vass Jan 1 '12 at 18:30
1  
good Q&A here that should help... askubuntu.com/questions/31888/… –  fossfreedom Jan 1 '12 at 18:33
    
Did you read man mount? df -T and mount describe the current state of the system. If you ran the commands before you mounted a .iso, ... –  waltinator Jan 1 '12 at 19:32
add comment

1 Answer 1

up vote 4 down vote accepted

The filetype you need for mounting a .iso formatted file is iso9660. Here's an example:

A good .iso:

walt@wombat:~(0)$ file  /usr/lib/memtest86+/memtest86+.iso  
/usr/lib/memtest86+/memtest86+.iso: # ISO 9660 CD-ROM filesystem data  MT410 ' (bootable)  `

A directory to mount it on:`

walt@wombat:~(0)$ ls -ld ~/tmp/mp  
drwxrwxr-x 2 walt walt 4096 2012-01-01 13:55 /home/walt/tmp/mp`  

The actual mount:

walt@wombat:~(1)$ sudo mount -t iso9660 /usr/lib/memtest86+/memtest86+.iso /home/walt/tmp/mp    
mount: warning: /home/walt/tmp/mp seems to be mounted read-only.`  

And here it is!

walt@wombat:~(0)$ ls !$  
ls /home/walt/tmp/mp  
boot  readme.txt  
walt@wombat:~(0)$  df -H /home/walt/tmp/mp  
Filesystem             Size   Used  Avail Use% Mounted on  
/dev/loop0             1.9M   1.9M      0 100% /home/walt/tmp/mp  
walt@wombat:~(0)$   
share|improve this answer
    
It may also be udf instead of iso9660. Likely if the image is meant for a DVD. –  psusi Jan 1 '12 at 19:25
    
That's why I used the file command, to be sure what the image was. –  waltinator Jan 1 '12 at 20:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.