Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My system is Ubuntu 11.10 64bit and i have to run a 32bit version of eclipse to use the TI plugins for CCSv5 but it doesn't work.

I tried to run eclipse in a 62bit java environment but it doesn't even start.

Now I got "java version "1.6.0_30"" from Sun in 32bit and now eclipse starts but can't use the TI plug ins and I get the following errors in bash:

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: falsche ELF-Klasse: ELFCLASS64

/usr/lib/gio/modules/libgvfsdbus.so: falsche ELF-Klasse: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

and this in a popup-window when Itry to use the plugin:

The selected wizard could not be started.
Plug-in com.ti.ccstudio.project.ui was unable to load class com.ti.ccstudio.project.ui.internal.wizards.importexport.temp.ExternalProjectImportWizard.
An error occurred while automatically activating bundle com.ti.ccstudio.project.ui (352).

T tested the libraries with file:

/usr/lib/gio/modules/libgvfsdbus.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

/usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

The ia32-libs are installed.

share|improve this question
add comment

1 Answer 1

I'm on 12.04 LTS x64.
Here's what worked for me:
sudo apt-get install ia32-libs
Installed Eclipse from repository
Installed the latest Target Management Terminal available from this eclipse plugin repo.
Enabled the http://rxtx.qbang.org/eclipse/ eclipse plugin repo.
Installed the latest RXTX plugin

It resulted in this:
enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.