Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I used Janitor tool to remove unused apps in ubuntu 11.10. I think I've removed some Unity specific libraries in the process. Now My screen look like plane vanila linux desktop without any unity launcher and top panel. even all unity specific effects are also gone.

  • I tried enabling the Unity plugin in ccsm and then resetting the unity.
  • I have tried unity --reset
  • I have tried reinstalling ubuntu-desktop
share|improve this question

closed as too localized by Jorge Castro, James, Nathan Osman, htorque, Bruno Pereira Jan 2 '12 at 22:21

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Try this: – Jorge Castro Jan 1 '12 at 15:42

If it is a matter of package that was uninstalled you can run this at terminal:

sudo apt-get install ubuntu-desktop
share|improve this answer
Thanks for the reply. I tried it but it says that ubuntu-desktop is already the newest version – Harish Kumar Jan 1 '12 at 15:19

You may be able to resolve broken applications by first uninstalling it then installing the it.

Since you're most likely already running the broken ubuntu-desktop, you might best log out, use the alt-F2 key to go to a terminal window and perform the task from there:

sudo apt-get remove ubuntu-desktop

sudo apt-get install ubuntu-desktop

This should at lease resolve the install error message you're getting.

share|improve this answer
Thanks for the reply but this didn't help either – Harish Kumar Jan 1 '12 at 16:52

I now restored the ubuntu using Installer and choosing the upgrade option. It just removed other extra programs which I had installed but My data remain intact. SO its now solved :)

share|improve this answer

To reset Unity to its default settings, you can use unity --reset. Using CCSM is known to cause issues if you're not very careful and know exactly what you're doing.

share|improve this answer
I tried unity --reset but it stops after the message -- Setting update "run_key" – Harish Kumar Jan 1 '12 at 15:22
Strange. Use Unity 2D until you can figure it out. – Jo-Erlend Schinstad Jan 1 '12 at 17:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.