Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 11.10 on my Inspiron N5030. Initially there were login sounds and all. But after some updates and software installation, now I'm not getting any alert sounds. However I get sounds when logged in as guest. I don't know which update worked wrong. I tried almost all solutions that provided in earlier posts... Please help me to solve it...

share|improve this question
    
do sounds work at all (i.e. other than system event alerts)? if it works on guest, maybe you have disabled/changed the sounds in system settings? –  Paulius Šukys Jan 1 '12 at 10:31
    
other media sounds all works. But no system alert sounds. –  gorbinnt Jan 9 '12 at 12:09
    
Check this one askubuntu.com/questions/81784/… –  user41374 Jan 10 '12 at 16:36

4 Answers 4

I have a fairly recent clean install of 11.10 with Gnome. One thing I've noticed with new installs is that the alert volume (separate from the normal volume) in system settings => sounds => sound effects seems to be set to minimum by default. This caused Skype sounds to not work.

I raise this, and Skype works correctly. the alert sounds all work correctly if I click on them in the sound dialog box. However, if a question alert pops up, such as one asking me if I want to save a file, there is no sound.

I discovered that it is not a sound problem at all; I discovered this by going into the system settings => universal access => hearing tab, and trying to enable "visual alerts". I tried this, and pressed the "Test flash" button, and nothing happened. So, the event is not being fired, it seems.

Then, I discovered that it is a Compiz problem. Changing to Metacity (running metacity --replace) makes it all work as expected. Changing back to Compiz (compiz --replace) makes it stop working again.

The results can be seen either in the Universal Access settings when pressing the test button, or in a terminal by typing echo -e "\a", which should make the chosen alert sound.

share|improve this answer
    
Edit: I did this in Gnome standard mode. In Unity, the window manager seems to disappear completely, although everything continues to run. But you would need to run Compiz from the terminal, as Alt-F2 doesn't respond (but Alt-Ctrl-T will, for the terminal). –  Marty Fried Jan 21 '12 at 1:24
1  
I entered this as a bug report in Compiz's bugzilla (bug #70). Hope someone notices it. –  Marty Fried Jan 21 '12 at 1:26
    
As a note, don't try metacity --replace in 12.10. It'll just lock things up :( –  Jeff Jan 25 '13 at 16:53

(Ubuntu 11.10 using gnome shell) there seems to be in bug in sound settings here. if you want to keep up the alert sounds ON first "unmute" and then raise the volume.

if you just raise the volume from zero to something e.g 50, then checkbox of mute displays unmute but actually its not.

after a month without alert sound i finally got upto it by an accident. lol :).

p.s. Please feel free to correct me if i am wrong.

share|improve this answer

I have a similar (possibly the same) problem. My sound works just fine in 11.10 64-bit install on dm1-4050 Sandy Bridge notebook (e.g. audio works in Banshee, flash, games, browser, Thunderbird email notification, etc.), but the core desktop notifications (e.g. pressing a tab in a terminal where there is more than one option should trigger a terminal notification sound, or changing volume using volume keys should be accompanied with the supporting "quack" that the volume app makes) do not work. I've intentionally disabled login sound as explained here on ask ubuntu but even enabling it back makes no difference.

Only things I did were trying to install some ppa edge xorg drivers for my intel card (a separate issue) but also reverted them all with ppa-purge once I discovered they did not improve anything. Other thing I did was check volume settings with alsamixer and did alsactl store for the soundcard after I did some experimenting with volume settings for PCM (on my laptop PCM at 100% crackles so I had to lower it and make pulseaudio ignore its setting). That said, neither of these should have any bearing on the said notifications since the volume is up and they clearly work everywhere else but the core desktop events (including the system ready drum sound when Ubuntu boots and user reaches the login screen).

I've tried copying ubuntu sounds to /usr/share/sounds/ as suggested on ask ubuntu and that did not work. I also tried using dconf-editor to check sound theme settings and tried both freedesktop (which is what it was set to) and ubuntu, as suggested on ask ubuntu. This did not work either. I tried purging ~/.pulse folder and the /tmp/pulse entries, rebooting and restarting pulseaudio with -D flag. While audio came back on and behaved just fine in all aspects (e.g. one can adjust volume levels, play music, games, in-browser sound stuff, and other app alerts) except for the system ready drum sound (at the login screen), and any system event (terminal bell and volume change quack sound). It is interesting that the quack sound works inside system settings->sound when adjusting levels there, but it does not when volume is changed via top bar's volume settings...

So, there you have it. I tried all I could find on this issue and had no luck so far... Any ideas?

share|improve this answer
    
I tried what Marty suggested below but even if I log into Unity2D (which I think has no compiz running), I still get no sound... Even the guest account doesn't get any... –  FlabbergastedPickle Jan 21 '12 at 17:35

using ubuntu 12.04, i installed ubuntu-tweak and on the Tweaks tab, enter the sound section and then enable Event sounds and choose a Sound theme (default "ubuntu").

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.