Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have unsuccessfully attempted to install a Canon LBP5000 printer on Ubuntu 11.10. I have attempted all possible methods to be found on the web, but nothing seems to work.

My latest attempt was Radu Cotescu's script from http://radu.cotescu.com/how-to-install-canon-lbp-printers-in-ubuntu/ Using the script everything appears to work as described during the installation process, but when attempting to actually print, it remains stuck in “processing” (regardless of what I attempt to print) [There is no additional error message].

Could anyone help me? It would be very much appreciated!

share|improve this question
    
any news? (askubuntu.com/a/106260/47206) –  cipricus Jan 27 '13 at 21:59
    
This question appears to be abandoned and unanswered, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. –  Aditya Feb 7 '13 at 18:56
add comment

closed as too localized by Eric Carvalho, Seth, bodhi.zazen, Minato Namikaze, hhlp Feb 8 '13 at 10:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

after install check

sudo /etc/init.d/ccpd status

when you see two numbers your printer is installed properly.......

Now take a test print........ if some error shows like,

Idle - /usr/lib/cups/filter/pstocapt

type

Sudo nautalis

type password for switching into root user. you will get a new browsing window with super user privillage

then copy the file named ccp from /usr/lib64/cups/backend to /usr/lib/cups/backend (if needed replace the ccp file in backend or keep as a backup with extension .bac)

Then copy the all files in /usr/lib64/cups/filter to /usr/lib/cups/filter

(similar way as above you can keep a backup if you want)

close the nautalis

Then test a print page......

and now your printer will work as you can see..

If not we have to try step by step install..... Before that I would like to know which version os Capt Driver you are using.......

share|improve this answer
    
I have the same issue, in Oneiric 11.10 (Xubuntu) with a Canon LBP-1120. I tried to follow rijrock's instructions but don't have a /usr/lib64 folder. There is an updated version of radu cotescu's script here. Larger discussion here. The driver is v.2.4-01. It didn't work for me. Rijrocks you seem to have the answer. Does the LBP driver really works in 11.10+ ? Have you used it? I have no feedback that it does, only that it does not!! –  cipricus Feb 20 '12 at 13:17
    
@cipricus Sure i have the proof. I am using my LBP2900B with ubuntu.. The procedures for 1120 have to be same.. but if you are not using a 64bit version of ubuntu, you likely won't have lib64 folder... I think i am not late to provide help you... :) could you please please download the latest version of CAPT Driver from this link website: i would like you to create a new question for this also provide me a link it. looking forward to it. i will do my best to help you –  rjkrocks Feb 26 '12 at 15:19
    
@cipricus Go the linked question.. :) But use the link i mentioned and download latest one.. –  rjkrocks Feb 26 '12 at 15:30
    
Thank you. I have created a question: askubuntu.com/questions/105891/…. –  cipricus Feb 27 '12 at 16:17
    
And found some answers too, in the sense that I know now the commands I have to make to start printing after logout. I have followed the step by step instructions on the Ubuntu official documentation site and now all I have to do is to reload a 'rules' file or something. I use 2.3 version for the moment and am pretty content with this state of affairs. Starting all the procedure again with 2.4 would make the printer work after reboot? Is bug #842823 solved? –  cipricus Feb 27 '12 at 16:24
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.